Don't distinguish an url or not for "Paste & Go"

RESOLVED FIXED in Firefox 4.0b8

Status

()

Firefox
Address Bar
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: ithinc, Assigned: fryn)

Tracking

Trunk
Firefox 4.0b8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre

The location bar accepts both urls and non-urls. It's unnecessary to distinguish the clipboard is an url or not for "Paste & Go" menuitem, just behave like pressing Enter key in the location bar. If ctrl- or middle-clicked, behave like pressing Alt+Enter key.

Reproducible: Always
(Reporter)

Updated

7 years ago
Blocks: 591635, 608111
(Assignee)

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
(Reporter)

Updated

7 years ago
Blocks: 601695

Comment 1

7 years ago
Also, if you have a url in the clipboard without the leading "http://" (e.g. "www.example.com"), Paste & Go is not shown.

Comment 2

7 years ago
I miss being able to "paste & go" keyword searches like "bug 611590" where "bug" was the keyword for "https://bugzilla.mozilla.org/buglist.cgi?quicksearch="
(Assignee)

Comment 3

7 years ago
Created attachment 491753 [details] [diff] [review]
patch

reverts bug 601695 patch to simpler, more predictable, and arguably more useful behavior.
Assignee: nobody → fryn
Status: NEW → ASSIGNED
Attachment #491753 - Flags: ui-review?(limi)
Attachment #491753 - Flags: review?(dolske)
(Assignee)

Updated

7 years ago
blocking2.0: --- → ?
Attachment #491753 - Flags: ui-review?(limi) → ui-review+
Attachment #491753 - Flags: review?(dolske)
Attachment #491753 - Flags: review+
Attachment #491753 - Flags: approval2.0+
blocking2.0: ? → betaN+
Also paste and search should be an option if clipboard contains multiple words.
(Assignee)

Comment 5

7 years ago
(In reply to comment #4)
By default, entering words into the location bar performs a search, so that is exactly what selecting "Paste & Go" will do.

---

Pushed.
http://hg.mozilla.org/mozilla-central/rev/924f8ac59812
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
No longer blocks: 591635
(Assignee)

Updated

7 years ago
Target Milestone: --- → Firefox 4.0b8

Updated

7 years ago
Duplicate of this bug: 613481

Updated

7 years ago
Duplicate of this bug: 614836
You need to log in before you can comment on or make changes to this bug.