Closed Bug 611635 Opened 9 years ago Closed 9 years ago

[OOPP][D2D][D3D10] Flash doesn't show its version in the about Flash page when OOPP and D3D10 is enabled

Categories

(Core :: Plug-ins, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: spammaaja, Assigned: bas.schouten)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre

Flash doesn't show its version in the about Flash page. Safe mode fixes.

Working:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101110 Firefox/4.0b8pre

Not working:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre

Reproducible: Always

Steps to Reproduce:
Go to the URL.

Actual Results:  
The "Version Information" box is empty.


Expected Results:  
Version should be displayed.


Clean profile.
Keywords: regression
Version: unspecified → Trunk
Related to Bug 596451 - Asynchronous layer-based plugin painting on Windows?
Could you be more specific? What "about Flash page"? How do you get to it? If safe-mode fixes the problem, it's unlikely to be related to bug 596451.
It works when dom.ipc.plugins.enabled is set to false.
Summary: Flash doesn't show its version in the about Flash page → Flash doesn't show its version in the about Flash page when OOPP is enabled
I cannot reproduce your issue. Trunk builds show 10,1,85,3 for me. Perhaps you have flashblock/adblock or something similar installed which is blocking the Flash embed used by that webpage to check the version?
Clean profile.
Also, as I said in the description, 20101110 works.

  Application Basics

        Name
        Firefox

        Version
        4.0b8pre

        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101112 Firefox/4.0b8pre

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        Norton IPS
        2.0
        false
        {BBDA0591-3099-440a-AA10-41764D9DB4DB}

        Norton Toolbar
        4.6
        false
        {2D3F3651-74B9-4795-BDEC-6DA2F431CB62}

  Modified Preferences

      Name

      Value

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20101112031632

        browser.startup.homepage_override.mstone
        rv:2.0b8pre

        extensions.lastAppVersion
        4.0b8pre

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        257673

        privacy.sanitize.migrateFx3Prefs
        true

  Graphics

        Adapter Description
        ATI Radeon HD 4600 Series

        Vendor ID
        1002

        Device ID
        9498

        Adapter RAM
        1024

        Adapter Drivers
        aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.782.0.0

        Driver Date
        9-28-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true

      GPU Accelerated Windows
      1/1 Direct3D 10
The only extensions are the global Norton extensions, which I have disabled.
Flash version: 10.1.102.64
I can confirm this issue with Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre SeaMonkey/2.1b2pre

The safemode disables all addons, jit(TM/JM) and the graphic hardware acceleration.

disabling my installed addon (adblock) and both JITs didn't change anything but setting gfx.direct2d.disabled to true makes it work !
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Flash doesn't show its version in the about Flash page when OOPP is enabled → Flash doesn't show its version in the about Flash page when OOPP or D2D is enabled
blocking2.0: --- → ?
Nominating for blocking. The version issue isn't a big thing, but the bug can affect the rendering of other flash apps too.
Summary: Flash doesn't show its version in the about Flash page when OOPP or D2D is enabled → [OOPP][D2D] Flash doesn't show its version in the about Flash page when OOPP or D2D is enabled
So dom.ipc.plugins.enabled;false or gfx.direct2d.disabled;true helps or both?
Is this limited to D2D10 and not happening on D2D9?
(In reply to comment #13)
> So dom.ipc.plugins.enabled;false or gfx.direct2d.disabled;true helps or both?
> Is this limited to D2D10 and not happening on D2D9?

There are two options to make the version visible:

1. Disable D2D (gfx.direct2d.disabled;true)
2. Disable OOPP (dom.ipc.plugins.enabled;false)

I think D2D9 doesn't exist. D2D was introduced with DirectX 10.
Disabling Direct3D 10 layers also helps. So, four options:

1. Disable D2D (gfx.direct2d.disabled;true)
2. Disable OOPP (dom.ipc.plugins.enabled;false)
3. Use D3D9 layers (layers.prefer-d3d9;true)
4. Disable layers acceleration (layers.accelerate-all;false)

Doing one of these four options "fixes" the problem.
Summary: [OOPP][D2D] Flash doesn't show its version in the about Flash page when OOPP or D2D is enabled → [OOPP][D2D][D3D10] Flash doesn't show its version in the about Flash page when OOPP, D2D or D3D10 is enabled
I wonder if https://bugzilla.mozilla.org/show_bug.cgi?id=611206 will fix this one also ?

It has a patch and r+ , wish someone would land it...
You'll note that bug still needed tests and had review comments to fix...
Bug 611206 is fixed now, is this still a problem in builds containing that fix?
(In reply to comment #18)
> Bug 611206 is fixed now, is this still a problem in builds containing that fix?

No, 611206 didn't fix this bug.
I expect this is a straight dup of bug 612686, which is mostly a dup of bug 601064.
Depends on: 601064
Bug 601064 appeared in Minefield 3.7pres (see comment 3 of that bug) while this appeared in the 20101111 build (4.0pre8), so how can this be a dupe of 601064?
Testing using the latest hourly based on cset: 
http://hg.mozilla.org/mozilla-central/rev/8714ad3e0704 which landed two bugs:
https://bugzilla.mozilla.org/show_bug.cgi?id=610737
https://bugzilla.mozilla.org/show_bug.cgi?id=612123

Seems to have fixed this bug, I now see the Flash Version in the 'Version Info box'
(In reply to comment #23)
> Testing using the latest hourly based on cset: 
> http://hg.mozilla.org/mozilla-central/rev/8714ad3e0704 which landed two bugs:
> https://bugzilla.mozilla.org/show_bug.cgi?id=610737
> https://bugzilla.mozilla.org/show_bug.cgi?id=612123
> 
> Seems to have fixed this bug, I now see the Flash Version in the 'Version Info
> box'

Not seeing that here. I re-enabled dom.ipc.plugins.enabled and the flash version disappeared.  Now I'm on https://hg.mozilla.org/mozilla-central/rev/0830d8f97936
(In reply to comment #24)
> (In reply to comment #23)
> > Testing using the latest hourly based on cset: 
> > http://hg.mozilla.org/mozilla-central/rev/8714ad3e0704 which landed two bugs:
> > https://bugzilla.mozilla.org/show_bug.cgi?id=610737
> > https://bugzilla.mozilla.org/show_bug.cgi?id=612123
> > 
> > Seems to have fixed this bug, I now see the Flash Version in the 'Version Info
> > box'
> 
> Not seeing that here. I re-enabled dom.ipc.plugins.enabled and the flash
> version disappeared.  Now I'm on
> https://hg.mozilla.org/mozilla-central/rev/0830d8f97936

Tested with fresh profile, and not seeing the info in the Version box - something in my cache must of fooled me - sorry :(
The text is there, it's just being rendered white. You can see this clearly in the embedded YouTube player, where the colour behind the text is grey (see attachment).

I toggled "Options > Advanced > General > Use Hardware Acceleration" on and off again and could see the text properly, even though Direct2D was active. When I restarted Firefox it was back to white on white though.
Bas, could you look into this? Seems related to hardware acceleration...
Assignee: nobody → bas.schouten
blocking2.0: ? → betaN+
In case of  enable D2D, D3D10 and OOPP.
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/212a391d3b79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110052514
Fails:
http://hg.mozilla.org/mozilla-central/rev/bdbef533364f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110081923
Pshlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=212a391d3b79&tochange=bdbef533364f
(In reply to comment #27)
> Bas, could you look into this? Seems related to hardware acceleration...

Considering the regression range I'm guessing bsmedberg might have a better idea of what's going on here.
Not really, other than my comments above. I think we need to fix bug 601064 and then retest some of these other bugs.
This bug is unrelated to Direct2D. It occurs when D3D10 layers -and- OOPP is enabled.
Summary: [OOPP][D2D][D3D10] Flash doesn't show its version in the about Flash page when OOPP, D2D or D3D10 is enabled → [OOPP][D2D][D3D10] Flash doesn't show its version in the about Flash page when OOPP and D3D10 is enabled
This is fixed by taking into account non-alpha surfaces. I've updated the patches on 615316 to do this because we first mentioned having to do this in that review trace.
Depends on: 615316
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
No longer depends on: 601064
You need to log in before you can comment on or make changes to this bug.