Closed Bug 611686 Opened 9 years ago Closed 9 years ago

Eliminate WARNING spew from nsCSSFrameConstructor

Categories

(Core :: Layout, defect, P4)

defect

Tracking

()

RESOLVED FIXED
mozilla2.0b8

People

(Reporter: sayrer, Assigned: dbaron)

Details

Attachments

(1 file)

No description provided.
I assume you mean:

WARNING: Positioned frame that does not handle positioned kids; looking further up the parent chain: file .../layout/base/nsCSSFrameConstructor.cpp, line 5565


Possible duplicate of bug 299315.
For the record, this is basically a warning saying "we haven't fixed bug 455338 yet"; we should probably ditch the warning.  Though it's a little scary that we hit it on startup, since that means there's something that depends on that bug in our chrome or start page.
Attached patch remove warningSplinter Review
Attachment #490134 - Flags: review?(bzbarsky)
Fwiw, we hit this warning any time we enter ContentRangeInserted with a XUL parentFrame that's rel-pos, even if there's nothing abs pos inside, since constructing the frame constructor state looks up the absolute containing block.

For browser.xul there's a rel pos button box frame that has kids dynamically inserted.
Comment on attachment 490134 [details] [diff] [review]
remove warning

r=me
Attachment #490134 - Flags: review?(bzbarsky) → review+
http://hg.mozilla.org/mozilla-central/rev/0b5df68704ad
Status: NEW → RESOLVED
Closed: 9 years ago
OS: Linux → All
Priority: -- → P4
Hardware: x86_64 → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Assignee: nobody → dbaron
You need to log in before you can comment on or make changes to this bug.