Closed Bug 612095 Opened 10 years ago Closed 8 years ago

Firefox 4.0b7 crash at startup [@ GeForceGLDriver@0x38bd72 ] on call to fCheckFramebufferStatus

Categories

(Core :: Graphics, defect)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- .x+

People

(Reporter: scoobidiver, Assigned: jrmuizel)

References

Details

(Keywords: crash, Whiteboard: [softblocker])

Crash Data

It is a crash signature in 4.0b7 on Mac OS X 64-bit.
It is #22 top crasher on Mac OS X in 4.0b7 for the last week.
May be it is related to bug 612090.

Signature	GeForceGLDriver@0x38bd72
UUID	46db5438-6e18-4d39-838d-e8edb2101112
Time 	2010-11-12 11:50:59.456704
Uptime	4
Install Age	4 seconds since version was first installed.
Product	Firefox
Version	4.0b7
Build ID	20101104131842
Branch	2.0
OS	Mac OS X
OS Version	10.6.5 10H574
CPU	amd64
CPU Info	family 6 model 23 stepping 10
Crash Reason	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address	0x0
App Notes 	Renderers: 0x22600,0x20400

Frame 	Module 	Signature [Expand] 	Source
0 	GeForceGLDriver 	GeForceGLDriver@0x38bd72 	
1 	GeForceGLDriver 	GeForceGLDriver@0x8e0e3 	
2 	GeForceGLDriver 	GeForceGLDriver@0xd238c 	
3 	GLEngine 	GLEngine@0xdd674 	
4 	GLEngine 	GLEngine@0xe49bd 	
5 	XUL 	mozilla::layers::LayerManagerOGL::Initialize 	
6 	XUL 	nsBaseWidget::GetLayerManager 	widget/src/xpwidgets/nsBaseWidget.cpp:826
7 	XUL 	-[ChildView drawRect:inContext:] 	widget/src/cocoa/nsChildView.mm:2696
8 	XUL 	-[ChildView drawRect:] 	widget/src/cocoa/nsChildView.mm:2610
9 	AppKit 	AppKit@0x100c48 	
10 	libSystem.B.dylib 	libSystem.B.dylib@0x66dd 	
11 	libSystem.B.dylib 	libSystem.B.dylib@0x6a02 	
12 	libSystem.B.dylib 	libSystem.B.dylib@0x6bf9 	
13 	libobjc.A.dylib 	libobjc.A.dylib@0x6c4b 	
14 	libobjc.A.dylib 	libobjc.A.dylib@0xcf9a 

More reports at:
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=GeForceGLDriver%400x38bd72&version=Firefox%3A4.0b7
possible way to reproduce this in https://bugzilla.mozilla.org/show_bug.cgi?id=623319#c8
Blocks: 623319
blocking2.0: --- → ?
Keywords: reproducible
That doesn't look like the same crash, unfortunately. However, please file that as a separate bug with that URL and we can get someone on it, since it's a reliable crash!

This, however, is a crash in OpenGL layer initialization. It might need to hardblock later.
blocking2.0: ? → final+
Component: XP Toolkit/Widgets: Menus → Graphics
QA Contact: xptoolkit.menus → thebes
Whiteboard: [softblocker]
Assignee: nobody → jmuizelaar
This doesn't seem to be happening very often. Perhaps it no longer blocks.
Depends on: 631645
Looks like we're crashing on a call to fCheckFramebufferStatus
Summary: Firefox 4.0b7 crash at startup [@ GeForceGLDriver@0x38bd72 ] → Firefox 4.0b7 crash at startup [@ GeForceGLDriver@0x38bd72 ] on call to fCheckFramebufferStatus
** PRODUCT DRIVERS PLEASE NOTE **

This bug is one of 7 automatically changed from blocking2.0:final+ to blocking2.0:.x during the endgame of Firefox 4 for the following reasons:

 - it was marked as a soft blocking issue without a requirement for beta coverage
blocking2.0: final+ → .x+
I think I found a reproducible url out of the crash data.

http://m8y.org/tmp/melusine/cjcliffe.github.com/CubicVR.js/cubicvr/tests/gpu_fluid/alpha_blocker_test.xhtml

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b13pre) Gecko/20110302 Firefox/4.0b13pre
does my crash in comment 6 and 7 look like the same bug or should we spin off another?
chofmann: Comment 6 looks like Bug 639100
Crash Signature: [@ GeForceGLDriver@0x38bd72 ]
I don't see any crashes in this specific signature, so can we close this one out? There are some other bugs such as Bug 682462 that are GeForce driver issues - is the root cause usually the same for these crashes?
(In reply to Marcia Knous [:marcia] from comment #10)
> I don't see any crashes in this specific signature, so can we close this one
> out?
Agreed.
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: reproducible
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.