Closed Bug 612179 Opened 9 years ago Closed 9 years ago

TEST FAILED: test-manifest.testE10sAdapterWorks (exception)

Categories

(Add-on SDK Graveyard :: General, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ashah, Unassigned)

References

Details

Attachments

(2 files)

SDK: changeset 4a60d23f96e4
Browser: FFx 4.0b7
Platform: Ubuntu 10.10

I ran my integration script against the mentioned changeset and found the
following error:

"TEST FAILED: test-manifest.testE10sAdapterWorks (exception)"
This error was followed by a bunch of failures and exceptions

Logs are available at:
http://pastebin.mozilla.org/852023


Note: FYI, The command that is executed from inside the integration script is:
"cfx testall -a firefox -b /home/mozilla/firefox/firefox"
OS: Mac OS X → All
Saw this on windows 7 as well for the changeset - 8074c3222e6c
The platform bug that triggers these failures was fixed today, so tomorrow's nightly builds should not trigger any such failures.

But this bug is about failures on 4.0b7, for which we supposedly disabled the e10s tests.  So it's not clear why they are failing on that build.

Given that we plan to make 4.0b7 the reference build for the next release of the SDK (unless perhaps 4.0b8 comes out in the meantime), this should block that release.
Blocks: 611250
Here's the output on Linux when I test the jetpack-core package on Firefox 4.0b7.
Fixed!

https://github.com/mozilla/addon-sdk/commit/571ec473ffc28f0f0191ea01af4a191bc307237c
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 613200
Note: I shoulder-reviewed the patch for this bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.