Hang with CSS filter property (loop of reflow and restyle?)

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
9 years ago
Last year

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks 1 bug, {hang, testcase})

Trunk
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

I think the CSS filter is central to the testcase and the <video> is not.
This seems to be the relevant stuck-loop:

1574  PresShell::FlushPendingNotifications
 1052  PresShell::ProcessReflowCommands
 383   nsCSSFrameConstructor::ProcessPendingRestyles
 111   nsIViewManager::UpdatEviewBatch::EndUpdateViewBatch
Can't reproduce on latest Nightly on Win7. Can you confirm?
Flags: needinfo?(jruderman)
Status: NEW → RESOLVED
Closed: Last year
Flags: in-testsuite+
Resolution: --- → WORKSFORME
Flags: needinfo?(jruderman)
You need to log in before you can comment on or make changes to this bug.