Closed Bug 612235 Opened 9 years ago Closed 9 years ago

"Forget about this site" makes Library a zombie.

Categories

(Firefox :: Bookmarks & History, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED FIXED
Firefox 4.0b8
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: andreea.pod, Assigned: mak)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101114 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101114 Firefox/4.0b8pre

I get no reaction from "Forget about this site", if triggered from Library's context menu. More, after calling this feature, the applet containing history list is blocked. 

Reproducible: Always

Steps to Reproduce:
1.Open History > Show All History from the main menu.
2.Right click and chose "Forget about this site" for an entry.
Actual Results:  
No entry is deleted and the Library window locks.

Expected Results:  
All the related pages of that site should be deleted and you could navigate through the remained pages with no problem.

Note: tested only against win7. regression range wanted?
This is confirmed for 

Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101114 Firefox/4.0b8pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: regression?
Flags: in-litmus?
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/4d99a78ddae4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre ID:20101112131930
Fails:
http://hg.mozilla.org/mozilla-central/rev/1911a8629c39
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101112 Firefox/4.0b8pre ID:20101112143830
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4d99a78ddae4&tochange=1911a8629c39
Blocks: 472343
Component: General → Bookmarks & History
QA Contact: general → bookmarks
taking for investigation.
Assignee: nobody → mak77
Blocks: 560198
Status: NEW → ASSIGNED
probably a blocker if the Library hangs.
blocking2.0: --- → ?
Keywords: hang, regression
Whiteboard: regression?
I also found that Library > Bookmarks can be blocked if chose "Forget about this site" for an item from Bookmarks Toolbar > Most Visited.
blocking2.0: ? → betaN+
Attached patch patch v1.0 (obsolete) — Splinter Review
This fixes both the above issues for me, it was nested batches calls.

Before going to central I'll push to try just to check that my assertion is safely handled (it should be much better than the old bogus warning).
Attachment #490676 - Flags: review?(dietrich)
Summary: "Forget about this site" from Library > History doesn't work properly. → "Forget about this site" makes Library a zombie.
fwiw, it's not really a hang, it's just that we stop handling selection events!
Keywords: hang
I believe this is in litmus (test case 11225).
Flags: in-litmus? → in-litmus+
Attachment #490676 - Flags: review?(dietrich) → review+
the NS_ABORT is still hitting a case in browser_library_left_pane_commands.js I'll try to debug it.
Attached patch patch v1.1Splinter Review
I'm removing the abort because it is triggering in absolutely common and valid situations. Tracking all batching levels from the source would require much deeper changes that are not worth the gain (that would just be having a correct abort) now.
Attachment #490676 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/bc41cecec7bd
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
Flags: in-testsuite+
This is still happening, build id:

Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110109 Firefox/4.0b9pre
(In reply to comment #12)
> This is still happening, build id:
> 
> Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110109
> Firefox/4.0b9pre

if that's the case that must be a new bug, so please file a new bug including steps to reproduce starting from a clean profile.
You need to log in before you can comment on or make changes to this bug.