"Always use Google to subscribe to feeds" setting ignored

RESOLVED FIXED in seamonkey2.1b2

Status

SeaMonkey
Feed Discovery and Preview
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Tristan Miller, Assigned: InvisibleSmiley)

Tracking

({fixed-seamonkey2.0.12})

Trunk
seamonkey2.1b2
fixed-seamonkey2.0.12

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.15) Gecko/20101026 SUSE/2.0.10-1.1 SeaMonkey/2.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.15) Gecko/20101026 SUSE/2.0.10-1.1 SeaMonkey/2.0.10

When I click on the feed icon in the location bar and select a feed from the drop-down list, SeaMonkey displays a page with a preview of the feed, and overtop that the following message:

Subscribe to this feed using [ News & Blogs ]
[ ] Always use News & Blogs to subscribe to feeds.
                         [ Subscribe Now ]

I use Google Reader as my aggregator, so I select "Google" from the drop down box, check the box next to "Always use Google to subscribe to feeds.", and then click on "Subscribe Now".  The feed is then added to Google Reader.

However, the next time I try to a subscribe to a feed, I get the same dialog.  Shouldn't having checked "Always use Google to subscribe to feeds" bypassed this?

I am not sure if this happens only with Google, or if it happens no matter what aggregator you select from the drop-down menu.

Reproducible: Always
(Assignee)

Comment 1

7 years ago
Confirming with current trunk on Win7. For some reason the browser.feeds.handler pref is not set to "reader" as happens with Minefield (Firefox trunk).

Setting version to Trunk because the bug it too minor to be fixed on branch anyway.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Version: unspecified → Trunk
(Assignee)

Comment 2

7 years ago
Created attachment 491005 [details] [diff] [review]
patch [Checkin: comments 4 and 7]

Cf. bug 415372 comment 45.
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #491005 - Flags: review?(neil)

Comment 3

7 years ago
Comment on attachment 491005 [details] [diff] [review]
patch [Checkin: comments 4 and 7]

Don't call it a "minor" patch, call it a "low risk" patch ;-)
Attachment #491005 - Flags: review?(neil) → review+
(Assignee)

Comment 4

7 years ago
Comment on attachment 491005 [details] [diff] [review]
patch [Checkin: comments 4 and 7]

http://hg.mozilla.org/comm-central/rev/681a70c2ce94
Attachment #491005 - Attachment description: patch → patch [Checkin: comment 4]
(Assignee)

Comment 5

7 years ago
(In reply to comment #3)
> Don't call it a "minor" patch, call it a "low risk" patch ;-)

Sounds like you suggest taking this for the next branch release... Anyway, this should bake at least some days/weeks on trunk first. Then asking for branch approval cannot hurt.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1b2
(Assignee)

Updated

7 years ago
Attachment #491005 - Flags: approval-seamonkey2.0.12?

Updated

7 years ago
Attachment #491005 - Flags: approval-seamonkey2.0.12? → approval-seamonkey2.0.12+
(Assignee)

Comment 6

7 years ago
Comment on attachment 491005 [details] [diff] [review]
patch [Checkin: comments 4 and 7]

FTR: This patch doesn't apply 1:1 to the 2.0 branch (the switch condition details have changed), so technically I should have attached a new patch. Since it's still only a one line removal I'll just check in the correct patch, though.
(Assignee)

Comment 7

7 years ago
Comment on attachment 491005 [details] [diff] [review]
patch [Checkin: comments 4 and 7]

http://hg.mozilla.org/releases/comm-1.9.1/rev/aa7f017b0531
Attachment #491005 - Attachment description: patch [Checkin: comment 4] → patch [Checkin: comments 4 and 7]
(Assignee)

Updated

7 years ago
Keywords: fixed-seamonkey2.0.12
You need to log in before you can comment on or make changes to this bug.