Last Comment Bug 612285 - Firefox Button menu does not disappear when I drag a bookmarks/history outside of the menu and submenu
: Firefox Button menu does not disappear when I drag a bookmarks/history outsid...
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: FirefoxButton
  Show dependency treegraph
 
Reported: 2010-11-15 08:09 PST by Alice0775 White
Modified: 2013-05-23 03:32 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.x+


Attachments

Description Alice0775 White 2010-11-15 08:09:55 PST
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101115 Firefox/4.0b8pre ID:20101115042202 

Firefox Button menu does not disappear when I drag a bookmarks/history outside of the menu and submenu.
This is difficult to drag item onto Bookmarks toolbar/Tabstrip.


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Enable Bookmarks Toolbar (If any)
3. Click Firefox Button
4. Open Bookmarks/History submenu
5. Try to Drag & Drop a bookmark/histrory item to Tabstrip/Bookmarks Toolbar


Actual Results:
 Firefox Button menu stay.

Expected Results:
 Firefox Button menu should disappear.
Comment 1 Dietrich Ayala (:dietrich) 2010-11-15 10:20:51 PST
Yep, menu should close -> blocking+.
Comment 2 :Margaret Leibovic 2010-12-08 15:21:56 PST
I tried investigating this, but I couldn't come up with a solution. I found multiple instances of node.localName == "menu" checks in places event handler code, and I suspect that may be causing a problem because the placespopup menupopups in the Firefox button menu are children of splitmenu nodes, not menu nodes.

Marco, do you have any thoughts on this?
Comment 3 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2010-12-15 10:36:49 PST
This is not serious enough to block, because the workaround of clicking anywhere (after the drag is done) is easy and obvious.
Comment 4 Dão Gottwald [:dao] 2013-05-23 03:32:47 PDT
The Firefox button is going to be removed in bug 863753.

Note You need to log in before you can comment on or make changes to this bug.