Closed Bug 612604 Opened 9 years ago Closed 5 months ago

Use content.scrollTo to update display port

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: stechz, Unassigned)

References

Details

In my tests, using content.scrollTo is much faster at rendering content than updating the displayport. The problem is, that we see gray lines (see bug 612599).
Depends on: 612599
Can this be fixed now?  And would it have any impact on getting "scroll" events when content scrolls (e.g. bug 654122)?
Blocks: 654122
Updating the scroll offset is no longer faster than updating the displayport thanks to incremental displayport updating, and it doesn't always work if the user pans to somewhere that doesn't change the scroll offset at all.

As we discussed on IRC, scroll events will currently not happen if the page dimensions are not big enough to extend the CSS viewport because the scroll range is 0, 0. I think this is the right thing to do, but we have floated the idea around of allowing "bogus" scroll offsets that won't make sense from a content POV.

At any rate, I think we should probably close this as WONTFIX. If we'd like fake scroll offsets, let's file something else. Objections?
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.