Export and Import of URL's during crash recovery

RESOLVED WONTFIX

Status

()

Firefox
Session Restore
--
enhancement
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Bob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

It would be so helpful if there were a way to export the list of URL's that get presented during a crash recovery. Along with the URL info, saving the window number, tab number, and groups/Panorama info would also be extremely helpful. Then along with this having the ability to import/export this same info from a currently running Firefox would be even better. The file would have the exact same structure of the entire state of the browser so it can be saved and restored. This would be helpful in saving different research environments, e.g. today I'm researching 25 different topics in 5 groups that I know I will need to return to next week, but in the mean time I have a completely different set of 30 topics in 6 groups that I need to do when I come in first thing tomorrow and having all these groups, tabs and/or windows puts too much load on the computer and consumes too much memory to be practical and effecient. The idea would also be great if you have a colleague who you would like to send this state of your browser so they can see how you came to a conclusion and if you both have the same browser state/setup it would make it so much easier to discuss the issues with each other.

The current crash recovery is a start, but it's currently limited to only letting you select or deselect the windows and tabs of the previous session to tell it which ones to start up this time. The ability to export this information plus the window/tab/group definitions that also existed when it crashed would go a long way in helping to document research scenarios. And then on top of that to have the complete ability to export and import these "browser state" files during the normal usage of Firefox would be even much more helpful.

Thanks...

Reproducible: Always

Steps to Reproduce:
1.N/A
2.
3.
Actual Results:  
N/A

Expected Results:  
N/A
(Reporter)

Comment 1

8 years ago
The feature would be needed in two places:

1. The crash recovery phase - would allow to restore all or part of the state of Firefox when it last crashed in case there was never any "save the state of Firefox" previously done.

2. General "save the state of Firefox" and "restore the state of Firefox" during normal usage of the browser. Perhaps another couple of menu items in the Bookmarks menu called "Save Firefox State" and "Restore Firefox State" which would bring up a file browser to either create this "state" or to restore a previous "state".

These facilities would be much more than a "Bookmark all tabs" - it would save all windows and all tabs and all group/panorama info - all the information that is needed to save and restore the current browser environment without resorting to a lot of work to recreate/restore the state of Firefox.
Firefox saves session state to a file in your profile (sessionstore.js). This file is what is read by Firefox to restore your windows, tabs, panorama data. You can move it, replace it with a different version, delete it, etc.

You might not want to send that file around since it will save session cookies for open websites (eg, if you're logged in to gmail and send that file to a friend, he/she may be logged in to your gmail account). So be aware of that.

(In reply to comment #1)
> 1. The crash recovery phase - would allow to restore all or part of the state
> of Firefox when it last crashed in case there was never any "save the state of
> Firefox" previously done.

Perhaps I'm misunderstanding, but this should work? Firefox will save your state when you crash even if you never explicitly told it to. We will attempt to restore that next time you start the browser.

> 2. General "save the state of Firefox" and "restore the state of Firefox"
> during normal usage of the browser. Perhaps another couple of menu items in the
> Bookmarks menu called "Save Firefox State" and "Restore Firefox State" which
> would bring up a file browser to either create this "state" or to restore a
> previous "state".

I don't believe this is something that should be in the core Firefox. This is for extensions and there are extensions that already do this. For example, session manager: https://addons.mozilla.org/en-US/firefox/addon/2324/ In fact, I think that does everything you need.

If I misinterpreted something let me know, but as is, this is WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

8 years ago
After looking at what the "Session Manager" add-on adds (and all the tweaks in it's preferences) I see what you mean about this not being something that fits into core Firefox. I've tried out this add-on and it seems like it's just what the doctor ordered. You can save/restore sessions that include all the group/Panorama info either on the same computer or to others by just copying the session files. 

Wonder if these "session files" are platform independent, i.e. can I take a Mac/Firefox-4 session file and use it on Windows and/or vice versa? The only thing it doesn't seem to do that I wish it did is export the URL's of all the tabs/windows to either a text file. Perhaps a script to strip out that info from the session file could be written?

Thanks very much for this tip.

I am enjoying the new Firefox 4.0 very very much - in fact switched it to be my default browser the same day I started using it last week (had been using Safari on a Mac). It hasn't crashed on me yet and it does some things I've wanted for a long time in a Safari browser but am giving up on it due to so many problems since 5.0 came out. Am so fed up with Safari and with the hangs and lost work and delays while I try to get back where I was.

Congrats to everyone who helped bring Firefox to the state it's in today. The idea of having groups using the Panorama interface is something I like really so much better than having all those windows to manage. I used to have anywhere from 6-10 windows in Safari with 50-75 tabs and now I can see having at most a couple of windows and only then if I need to see two or more sites at the same time to visually compare something I'm working on. And really like the idea of pre-pending the group name onto the title of the window - it helps to remind me what I'm looking at and also in letting me organize my brain into what group of tabs I'm really working on.

Thanks again...

-Bob
You need to log in before you can comment on or make changes to this bug.