When in save file dialog, download error message pops up and makes browser unresponsive.

RESOLVED DUPLICATE of bug 476541

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 476541
7 years ago
7 years ago

People

(Reporter: vossman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

I clicked on a broken link on a server that takes forever to respond. I then continue to try and save a file. While in the file save dialog, the original server responds with a download error.

Reproducible: Always

Steps to Reproduce:
1. Use 'Save link as...' on a broken link (#1) with a server that takes a long time to respond.
2. Use 'Save link as...' on a good link (#2)
3. 'Enter name of file to save to...' save file dialog open as asks for file name of link #2
4. Link #1 gets a 'Download Error' error message dialog
5. While save file dialog is in front, but clicking on save button has no action. Second, error message dialog is not accessible to click ok.
6. Force kill browser and start over.
Actual Results:  
Browser locks up. It is not really locked up by I can only click cancel and save and neither close the save as window.

Expected Results:  
No lock up, click on OK and then Save and continue browsing.
(Reporter)

Comment 1

7 years ago
Created attachment 491637 [details]
Screen capture of double window situation
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.