Closed Bug 613321 Opened 9 years ago Closed 9 years ago

11/18 nightly won't start on Galaxy S

Categories

(Core :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
fennec 2.0b3+ ---

People

(Reporter: jdm, Unassigned)

Details

Attachments

(1 file)

I installed the nightly after uninstalling my self-signed package.  The first time it started, but I didn't have a VKB.  From then on, it freezes on startup showing a white content box and the throbber is in mid-throb.  Logcat output:

I/ActivityManager( 2243): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.mozilla.fennec/.App bnds=[5,234][115,372] }
D/SamsungWidgetNetworkInfo( 2326): SamsungWidgetNetworkInfo: onPause()
D/Launcher( 2326): launcher is paused
V/AudioHardwareALSA( 2183): 
V/AudioHardwareALSA( 2183): ------------------------>>>>>> ALSA OPEN mode 0,device 2 
I/AudioHardwareALSA( 2183): Initialized ALSA PLAYBACK device AndroidPlayback_Speaker_normal
D/AudioHardwareALSA( 2183): Set PLAYBACK PCM format to S16_LE (Signed 16 bit Little Endian)
D/AudioHardwareALSA( 2183): Using 2 channels for PLAYBACK.
D/AudioHardwareALSA( 2183): Set PLAYBACK sample rate to 44100 HZ
D/AudioHardwareALSA( 2183): Buffer size: 4096
D/AudioHardwareALSA( 2183): Latency: 92879
I/ActivityManager( 2243): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=3812 uid=10080 gids={3003, 1015}
I/Zygote  ( 3812): Zygote: pid 3812 has INTERNET permission, then set capability for CAP_NET_RAW(13)
W/Resources( 2243): Converting to boolean: TypedValue{t=0x3/d=0x140f "res/anim/accelerate_decelerate_interpolator.xml" a=1 r=0x10a0004}
W/Resources( 2243): Converting to boolean: TypedValue{t=0x3/d=0x140f "res/anim/accelerate_decelerate_interpolator.xml" a=1 r=0x10a0004}
D/dalvikvm( 3812): GC freed 1865 objects / 148288 bytes in 34ms
D/dalvikvm( 3812): GC freed 1900 objects / 156240 bytes in 38ms
I/GeckoApp( 3812): create
I/GeckoApp( 3812): start
I/dalvikvm( 3812): Could not find method android.util.Base64.decode, referenced from method org.mozilla.gecko.GeckoAppShell.installWebApplication
W/dalvikvm( 3812): VFY: unable to resolve static method 91: Landroid/util/Base64;.decode (Ljava/lang/String;I)[B
D/dalvikvm( 3812): VFY: replacing opcode 0x71 at 0x0081
D/dalvikvm( 3812): Making a copy of Lorg/mozilla/gecko/GeckoAppShell;.installWebApplication code (324 bytes)
I/GeckoAppJava( 3812): Checking for an update
I/global  ( 3812): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
D/dalvikvm( 3812): Trying to load lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x47a93bb0
D/dalvikvm( 3812): Added shared lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x47a93bb0
D/dalvikvm( 3812): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozutils.so 0x47a93bb0
I/GeckoApp( 3812): env0: null
D/dalvikvm( 3812): +++ not scanning '/system/lib/libwebcore.so' for 'putenv' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libmedia_jni.so' for 'putenv' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libexif.so' for 'putenv' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libwebcore.so' for 'loadLibs' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libmedia_jni.so' for 'loadLibs' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libexif.so' for 'loadLibs' (wrong CL)
D/dalvikvm( 3812): GC freed 2197 objects / 167592 bytes in 29ms
I/GeckoAppJava( 3812): installing extension : extensions/feedback@mobile.mozilla.org.xpi
D/dalvikvm( 3812): +++ not scanning '/system/lib/libwebcore.so' for 'nativeInit' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libmedia_jni.so' for 'nativeInit' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libexif.so' for 'nativeInit' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libwebcore.so' for 'setSurfaceView' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libmedia_jni.so' for 'setSurfaceView' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libexif.so' for 'setSurfaceView' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libwebcore.so' for 'nativeRun' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libmedia_jni.so' for 'nativeRun' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libexif.so' for 'nativeRun' (wrong CL)
I/GeckoApp( 3812): resume
D/dalvikvm( 3812): GC freed 1990 objects / 191872 bytes in 68ms
I/GeckoAppJava( 3812): surfaceChanged: fmt: -1 dim: 480 762
I/ActivityManager( 2243): Displayed activity org.mozilla.fennec/.App: 1313 ms (total 1313 ms)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libwebcore.so' for 'notifyGeckoOfEvent' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libmedia_jni.so' for 'notifyGeckoOfEvent' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libexif.so' for 'notifyGeckoOfEvent' (wrong CL)
I/Gecko   ( 3812): Font: /system/fonts/DroidSansFallback.ttf
I/Gecko   ( 3812): font family: Droid Sans Fallback
I/Gecko   ( 3812): Font: /system/fonts/Clockopia.ttf
I/Gecko   ( 3812): font family: Clockopia
I/Gecko   ( 3812): Font: /system/fonts/DroidSerif-Italic.ttf
I/Gecko   ( 3812): font family: Droid Serif
I/Gecko   ( 3812): Font: /system/fonts/DroidSans-Bold.ttf
I/Gecko   ( 3812): font family: Droid Sans
I/Gecko   ( 3812): Font: /system/fonts/DroidSans.ttf
I/Gecko   ( 3812): font family: Droid Sans
I/Gecko   ( 3812): Font: /system/fonts/DroidSerif-Regular.ttf
I/Gecko   ( 3812): font family: Droid Serif
I/Gecko   ( 3812): Font: /system/fonts/DroidSerif-BoldItalic.ttf
I/Gecko   ( 3812): font family: Droid Serif
I/Gecko   ( 3812): Font: /system/fonts/DroidSansMono.ttf
I/Gecko   ( 3812): font family: Droid Sans Mono
I/Gecko   ( 3812): Font: /system/fonts/DroidSerif-Bold.ttf
I/Gecko   ( 3812): font family: Droid Serif
W/PowerManagerService( 2243): Timer 0x3->0x3|0x0
I/Gecko   ( 3812): nsWindow::GetLayerManager
I/Gecko   ( 3812):  -- creating basic, not accelerated
I/Gecko   ( 3812): nsWindow::GetLayerManager
I/Gecko   ( 3812):  -- creating basic, not accelerated
D/dalvikvm( 3812): GC freed 13233 objects / 1009688 bytes in 36ms
I/AudioHardwareALSA( 2183): Output standby called!!. Turn off PCM device.
D/dalvikvm( 2446): GC freed 934 objects / 40760 bytes in 186ms
D/dalvikvm( 2464): GC freed 601 objects / 39336 bytes in 186ms
I/WindowManager( 2243): Setting rotation to 3, animFlags=0
I/ActivityManager( 2243): Config changed: { scale=1.0 imsi=0/0 loc=en_GB touch=3 keys=1/1/2 nav=1/1 orien=2 layout=34 FlipFont=0}
D/PhoneWindow( 3812): couldn't save which view has focus because the focused view org.mozilla.gecko.GeckoSurfaceView@47a90868 has no id.
I/GeckoApp( 3812): pause
I/GeckoApp( 3812): stop
I/GeckoApp( 3812): destroy
I/GeckoAppJava( 3812): surface destroyed
I/UsageStats( 2243): Unexpected resume of org.mozilla.fennec while already resumed in org.mozilla.fennec
I/GeckoApp( 3812): create
I/GeckoApp( 3812): start
V/SettingsProvider( 2243): system <- value=1.0 name=font_scale
I/GeckoApp( 3812): resume
V/SettingsProvider( 2243): property: sys.settings_system_version=47
D/dalvikvm( 3812): +++ not scanning '/system/lib/libwebcore.so' for 'onResume' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libmedia_jni.so' for 'onResume' (wrong CL)
D/dalvikvm( 3812): +++ not scanning '/system/lib/libexif.so' for 'onResume' (wrong CL)
V/SettingsProvider( 2243): notifying: content://settings/system/font_scale
I/AlarmManager( 2243): mWakeLock.acquire(500);
W/WindowManager( 2243): Window freeze timeout expired.
W/WindowManager( 2243): Force clearing orientation change: Window{47b17858 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
D/WifiService( 2243): ACTION_BATTERY_CHANGED pluggedType: 2
I/WifiService( 2243): handleMessage: MESSAGE_ENABLE_WIFI
I/WifiService( 2243): handleMessage: MESSAGE_START_WIFI
I/StatusBarPolicy( 2243): BAT. status:2 health:2
I/AlarmManager( 2243): mWakeLock.acquire(500);
W/WindowManager( 2243): App freeze timeout expired.
W/WindowManager( 2243): Force clearing freeze: AppWindowToken{48030210 token=HistoryRecord{47a847f0 org.mozilla.fennec/.App}}
D/dalvikvm( 2243): GC freed 11063 objects / 545808 bytes in 312ms
D/dalvikvm( 2326): GC freed 2995 objects / 144504 bytes in 216ms
D/dalvikvm( 3306): GC freed 271 objects / 10312 bytes in 181ms
D/dalvikvm( 2330): GC freed 98 objects / 6376 bytes in 169ms
OS: Mac OS X → Android
Hardware: x86 → ARM
I can reproduce.  I see the URL bar and a blank home screen appear, but then nothing changes.  Switching device orientation leads to a black window that's never repainted.  I sampled the java and gecko threads over a period of a minute or so, and never saw either with a different backtrace than

=== gecko ===
Thread 2 (Thread 28333):
#0  0xafe0d9c4 in __futex_wait () from libc.so
#1  0xafe0f444 in __pthread_cond_timedwait_relative () from libc.so
#2  0xafe0f4d0 in __pthread_cond_timedwait () from libc.so
#3  0x81d16894 in PR_WaitCondVar (cvar=0x4f36fbf0, timeout=4294967295) at /home/cjones/mozilla/mozilla-central/nsprpub/pr/src/pthreads/ptsynch.c:417
#4  0x8484c6ba in nsAppShell::ProcessNextNativeEvent (this=0x4f37ac80, mayWait=1) at /home/cjones/mozilla/mozilla-central/widget/src/android/nsAppShell.cpp:152
#5  0x84851e6e in nsBaseAppShell::DoProcessNextNativeEvent (this=0xfffffe00, mayWait=0) at /home/cjones/mozilla/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:162
#6  0x8485203e in nsBaseAppShell::OnProcessNextEvent (this=0x4f37ac80, thr=0x4d20c740, mayWait=1, recursionDepth=<value optimized out>) at /home/cjones/mozilla/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:321
#7  0x84881286 in mozilla::dom::ContentParent::OnProcessNextEvent (this=<value optimized out>, thread=0x0, mayWait=-128, recursionDepth=0) at /home/cjones/mozilla/mozilla-central/dom/ipc/ContentParent.cpp:580
#8  0x8494d2b4 in nsThread::ProcessNextEvent (this=0x4d20c740, mayWait=1, result=<value optimized out>) at /home/cjones/mozilla/mozilla-central/xpcom/threads/nsThread.cpp:577
#9  0x84927b7e in NS_ProcessNextEvent_P (thread=0xfffffe00, mayWait=1) at nsThreadUtils.cpp:250
#10 0x84893662 in mozilla::ipc::MessagePump::Run (this=0x4d20f2e0, aDelegate=0x4d2140c0) at /home/cjones/mozilla/mozilla-central/ipc/glue/MessagePump.cpp:134
#11 0x84972efe in MessageLoop::RunInternal (this=0x4d2140c0) at /home/cjones/mozilla/mozilla-central/ipc/chromium/src/base/message_loop.cc:219
#12 0x84972f5c in RunHandler (this=0x4d20c740) at /home/cjones/mozilla/mozilla-central/ipc/chromium/src/base/message_loop.cc:202
#13 MessageLoop::Run (this=0x4d20c740) at /home/cjones/mozilla/mozilla-central/ipc/chromium/src/base/message_loop.cc:176
#14 0x84852120 in nsBaseAppShell::Run (this=0x4f37ac80) at /home/cjones/mozilla/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:181
#15 0x84791bcc in nsAppStartup::Run (this=0x4f3992e0) at /home/cjones/mozilla/mozilla-central/toolkit/components/startup/src/nsAppStartup.cpp:191
#16 0x842138a4 in XRE_main (argc=<value optimized out>, argv=<value optimized out>, aAppData=<value optimized out>) at /home/cjones/mozilla/mozilla-central/toolkit/xre/nsAppRunner.cpp:3682
#17 0x842167ba in GeckoStart (data=0x4d20c650) at /home/cjones/mozilla/mozilla-central/toolkit/xre/nsAndroidStartup.cpp:131
#18 0xafe0fdd8 in __thread_entry () from libc.so
#19 0xafe0f8a4 in pthread_create () from libc.so
#20 0x00000000 in ?? () from libm.so

=== java ===
java.lang.Object	wait	Object.java	-2	true	
java.lang.Thread	parkFor	Thread.java	1535	false	
java.lang.LangAccessImpl	parkFor	LangAccessImpl.java	48	false	
sun.misc.Unsafe	park	Unsafe.java	317	false	
java.util.concurrent.locks.LockSupport	park	LockSupport.java	131	false	
java.util.concurrent.locks.AbstractQueuedSynchronizer	parkAndCheckInterrupt	AbstractQueuedSynchronizer.java	790	false	
java.util.concurrent.locks.AbstractQueuedSynchronizer	acquireQueued	AbstractQueuedSynchronizer.java	823	false	
java.util.concurrent.locks.AbstractQueuedSynchronizer	acquire	AbstractQueuedSynchronizer.java	1153	false	
java.util.concurrent.locks.ReentrantLock$NonfairSync	lock	ReentrantLock.java	185	false	
java.util.concurrent.locks.ReentrantLock	lock	ReentrantLock.java	261	false	
org.mozilla.gecko.GeckoSurfaceView	surfaceChanged	GeckoSurfaceView.java	98	false	
android.view.SurfaceView	updateWindow	SurfaceView.java	460	false	
android.view.SurfaceView	dispatchDraw	SurfaceView.java	287	false	
android.view.ViewGroup	drawChild	ViewGroup.java	1531	false	
android.view.ViewGroup	dispatchDraw	ViewGroup.java	1260	false	
android.view.ViewGroup	drawChild	ViewGroup.java	1531	false	
android.view.ViewGroup	dispatchDraw	ViewGroup.java	1260	false	
android.view.View	draw	View.java	6600	false	
android.widget.FrameLayout	draw	FrameLayout.java	352	false	
android.view.ViewGroup	drawChild	ViewGroup.java	1533	false	
android.view.ViewGroup	dispatchDraw	ViewGroup.java	1260	false	
android.view.View	draw	View.java	6600	false	
android.widget.FrameLayout	draw	FrameLayout.java	352	false	
com.android.internal.policy.impl.PhoneWindow$DecorView	draw	PhoneWindow.java	1884	false	
android.view.ViewRoot	draw	ViewRoot.java	1374	false	
android.view.ViewRoot	performTraversals	ViewRoot.java	1139	false	
android.view.ViewRoot	handleMessage	ViewRoot.java	1658	false	
android.os.Handler	dispatchMessage	Handler.java	99	false	
android.os.Looper	loop	Looper.java	123	false	
android.app.ActivityThread	main	ActivityThread.java	4363	false	
java.lang.reflect.Method	invokeNative	Method.java	-2	true	
java.lang.reflect.Method	invoke	Method.java	521	false	
com.android.internal.os.ZygoteInit$MethodAndArgsCaller	run	ZygoteInit.java	862	false	
com.android.internal.os.ZygoteInit	main	ZygoteInit.java	620	false	
dalvik.system.NativeStart	main	NativeStart.java	-2	true


The main thread is sitting idle in its event loop, and the java thread is blocked on a (pthread) condvar that apparently never gets notified.  Looks like a wire is getting crossed somewhere, threading-wise.

This needs to block b3.
tracking-fennec: --- → ?
Severity: normal → critical
FTR this has nothing to do with the JITs.  Since I've lost my credibility there ;), I wrote the patch in bug 613367 and it reports my vibrant as blacklisted, as expected.
from the logcat of a debug build:
I/Gecko   ( 7782): WARNING: NS_ENSURE_TRUE(mMainThread) failed: file ../../../xpcom/threads/nsThreadManager.cpp, line 284
I/Gecko   ( 7782): WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0xC1F30001: file nsThreadUtils.cpp, line 173
I/Gecko   ( 7782): WARNING: NS_ENSURE_TRUE(mMainThread) failed: file ../../../xpcom/threads/nsThreadManager.cpp, line 284
I/Gecko   ( 7782): WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0xC1F30001: file nsThreadUtils.cpp, line 173
I/Gecko   ( 7751): nsWindow[0x50ba71d0]::Create 0x0 [0 0 0 0]
I/Gecko   ( 7751): nsWindow[0x50ba71d0]::SetZIndex 2147483647 ignored
I/Gecko   ( 7751): nsWindow[0x50ba71d0]::Show 0
I/Gecko   ( 7751): nsWindow[0x50ba75c0]::Create 0x0 [0 0 0 0]
I/Gecko   ( 7751): nsWindow[0x50ba75c0]::SetZIndex 2147483647 ignored
I/Gecko   ( 7751): nsWindow[0x50ba75c0]::Show 0
I/AlarmManager( 2242): mWakeLock.acquire(500);
I/Gecko   ( 7751): WARNING: NS_ENSURE_SUCCESS(result, result) failed with result 0x80004005: file ../../../../editor/libeditor/base/nsEditor.cpp, line 3896
I/Gecko   ( 7751): WARNING: NS_ENSURE_SUCCESS(res, res) failed with result 0x80004005: file ../../../../editor/libeditor/text/nsTextEditRules.cpp, line 471
I/Gecko   ( 7751): nsWindow 0x50ba71d0 destructor
I/Gecko   ( 7751): nsWindow::Invalidate 0x4dd69c90 [0 0 480 762]
I/Gecko   ( 7751): nsWindow::Invalidate 0x4dd69c90 [23 24 33 32]
I/Gecko   ( 7751): >> OnDraw
I/Gecko   ( 7751): nsWindow[0x4dd69c90]::DrawTo no covering child, drawing this
I/Gecko   ( 7751): nsWindow::Invalidate 0x4dd69c90 [23 24 33 32]
I/Gecko   ( 7782): ###!!! ASSERTION: Potential deadlock between nsComponentManagerImplMonitor@41112520 and Lock@41182f60: 'Error', file nsAutoLock.cpp, line 318
I/Gecko   ( 7751): >> OnDraw
I/Gecko   ( 7751): nsWindow[0x4dd69c90]::DrawTo no covering child, drawing this
I/Gecko   ( 7782): ###!!! ASSERTION: Potential deadlock between nsComponentManagerImplMonitor@41112520 and Lock@41182f60: 'Error', file nsAutoLock.cpp, line 318
I/Gecko   ( 7782): ###!!! ASSERTION: Potential deadlock between nsComponentManagerImplMonitor@41112520 and Lock@41182f60: 'Error', file nsAutoLock.cpp, line 318
I/Gecko   ( 7782): ###!!! ASSERTION: Potential deadlock between nsComponentManagerImplMonitor@41112520 and Lock@41182f60: 'Error', file nsAutoLock.cpp, line 318
I/Gecko   ( 7782): ###!!! ASSERTION: Potential deadlock between nsComponentManagerImplMonitor@41112520 and Lock@41182f60: 'Error', file nsAutoLock.cpp, line 318
I/Gecko   ( 7782): ###!!! ASSERTION: Potential deadlock between nsComponentManagerImplMonitor@41112520 and Lock@41182f60: 'Error', file nsAutoLock.cpp, line 318
I/Gecko   ( 7782): ###!!! ASSERTION: Potential deadlock between nsComponentManagerImplMonitor@41112520 and Lock@41182f60: 'Error', file nsAutoLock.cpp, line 318
I/Gecko   ( 7782): ###!!! ASSERTION: Potential deadlock between nsComponentManagerImplMonitor@41112520 and Lock@41182f60: 'Error', file nsAutoLock.cpp, line 318
I/Gecko   ( 7782): WARNING: Error reading channel-prefs.js: file ../../../../modules/libpref/src/nsPrefService.cpp, line 903
W/PowerManagerService( 2242): Timer 0x7->0x3|0x0
this looks like a bad merge. The two parents of http://hg.mozilla.org/mozilla-central/rev/78a42f77bb90 work fine. The bustage fix follow up from the merge (http://hg.mozilla.org/mozilla-central/rev/35f8ec6fa9e6) exhibits the hang.
based on the bisect, I'm moving this to core js
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Fennec → Core
QA Contact: general → general
tracking-fennec: ? → 2.0b3+
Assignee: general → nobody
Component: JavaScript Engine → General
Product: Core → Fennec
QA Contact: general → general
There's no evidence that this is a JS bug. Aside from that, there's no evidence that the Samsung Galaxy S is a sound platform to build on.
I/Gecko   ( 7782): WARNING: NS_ENSURE_TRUE(mMainThread) failed: file
../../../xpcom/threads/nsThreadManager.cpp, line 284

This, and all of the other warnings in Comment 3, point to a threading problem in Fennec. It could be that the TM merge made a pre-existing bug bite. Or, maybe a concurrent change in the mobile repo triggered this (did any one check that?).
Do current tinderbox builds show this problem?
(In reply to comment #8)
> Or,
> maybe a concurrent change in the mobile repo triggered this (did any one check
> that?).

my testing has kept the mobile-browser changeset constant, so that's not it
(In reply to comment #10)
> (In reply to comment #8)
> > Or,
> > maybe a concurrent change in the mobile repo triggered this (did any one check
> > that?).
> 
> my testing has kept the mobile-browser changeset constant, so that's not it

Please list the changesets tested in the original bug report, and the changesets you are testing now.
m-b ad19e9b8a957 + m-c a86f1ab3f3db works
m-b ad19e9b8a957 + m-c 08794e076ded works
m-b ad19e9b8a957 + m-c 35f8ec6fa9e6 hangs
Those changesets are from two days ago. Is it still broken? We did do one backout yesterday.
Todays nightly is still very much broken
Alright, I think the easiest thing to do next is pull mozilla-central into TM, and see if that results in a broken mobile build on the Samsung Galaxy S. The code bases should be almost identical.
At this point, there are two questions to ask:

1.) Is anyone investigating the thread-safety assertions in Fennec?

2.) Is anyone automating Samsung Galaxy S tests?

Having to deal with a browser that doesn't start up on a Friday night is an indication of an immature engineering organization.
I think we should go ahead and back out the TM merge until we have a solution in place that lets people continue to test as we have a release code freeze coming on Tuesday.  Will start working on that now, and kick off a build on TM
(In reply to comment #17)
> I think we should go ahead and back out the TM merge

Absolutely not. afaik, the Samsung Galaxy S is not a tier-1 platform.
I merged mozilla-central to tracemonkey:

http://hg.mozilla.org/tracemonkey/rev/6f7f0da15693
Brad and I re-bisected this, after realizing that builds would start the first time after being installed fresh but not afterwards.  Have found that it is caused by bug 604712 (not sure why yet).  Have backed it out.
Product: Fennec → Core
QA Contact: general → general
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.