Closed Bug 613365 Opened 9 years ago Closed 9 years ago

If URL in locationbar is selected, hovering a link overlays a blue area on top of the selected URL

Categories

(Firefox :: Address Bar, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0b8

People

(Reporter: whimboo, Assigned: adw)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101117 Firefox/4.0b8pre ID:20101117030837

Hovering over a link while the URL in the location bar is selected produces a blue area on top of the selected URL.

Steps:
1. Press Cmd/Ctrl+L to focus the location bar and select the whole URL
2. Hover over a link


On Windows we do not show up the link url in the location bar. Another bug?
blocking2.0: --- → ?
Attached image screenshot
Blocks: 613375
There may be changes to this feature in bug 613390, but I think this should definitely get fixed.
(In reply to comment #2)
> There may be changes to this feature in bug 613390, but I think this should
> definitely get fixed.

Lets put it onto the dependency list for easier tracking.
Depends on: 613390
Duplicate of this bug: 613418
No longer blocks: 613375
Crap, my fix for bug 597581 or bug 612828 must have caused this.
Assignee: nobody → adw
Status: NEW → ASSIGNED
(In reply to comment #0)
> On Windows we do not show up the link url in the location bar. Another bug?

Bug 597841 -- it's not a bug, it's by design, it's supposed to be like that for all platforms and was until recently.
No longer depends on: 613390
My fix to bug 597581 caused this.
Blocks: 597581
Attached patch patch (obsolete) — Splinter Review
This should work.  Rebuilding now to check.
The patch to bug 597581 erroneously removed a this.focused check.
Attachment #491952 - Attachment is obsolete: true
Attachment #491968 - Flags: review?(dao)
Attachment #491968 - Flags: review?(dao) → review+
Attachment #491968 - Flags: approval2.0?
Attachment #491968 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/8af7288622ea
Status: ASSIGNED → RESOLVED
blocking2.0: ? → ---
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
Verified fixed on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101122 Firefox/4.0b8pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.