IndexedDB: Success event for setVersion request has wrong result

RESOLVED FIXED

Status

()

Core
DOM: IndexedDB
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: sicking, Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

The result should be the new transaction, it is currently null in our impl.
Summary: Success event for setVersion request has wrong result → IndexedDB: Success event for setVersion request has wrong result
blocking2.0: --- → ?
Created attachment 497019 [details] [diff] [review]
Patch, v1
Attachment #497019 - Flags: review?(jonas)
Created attachment 497020 [details] [diff] [review]
Patch, v1

Oops, this is the right patch.
Attachment #497019 - Attachment is obsolete: true
Attachment #497020 - Flags: review?(jonas)
Attachment #497019 - Flags: review?(jonas)
Attachment #497020 - Flags: review?(jonas) → review+
blocking2.0: ? → final+
Duplicate of this bug: 613368
http://hg.mozilla.org/mozilla-central/rev/39811128613a
blocking2.0: final+ → ?
Status: NEW → RESOLVED
blocking2.0: ? → ---
Last Resolved: 7 years ago
Resolution: --- → FIXED
Component: DOM → DOM: IndexedDB
You need to log in before you can comment on or make changes to this bug.