Closed Bug 613406 Opened 14 years ago Closed 14 years ago

Tinypic.com rendering problems preventing you from retrieving [IMG] code after uploading an image when OOPP for Flash Player Enabled.

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Windows XP
defect
Not set
major

Tracking

(blocking2.0 betaN+)

RESOLVED WORKSFORME
mozilla2.0
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: rob64rock, Assigned: jimm)

References

()

Details

(Keywords: regression, Whiteboard: [softblocker])

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101118 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101118 Firefox/4.0b8pre

Tinypic.com rendering problems preventing you from retrieving [IMG] code after up loading an image when OOPP for Flash Player Enabled. Screenshot here: http://i56.tinypic.com/2lw52t2 , Adding this "dom.ipc.plugins.enabled.npswf32.dll;false" in about:config fixes the rendering problem. Screenshot here: http://i54.tinypic.com/344p0fs
Note: Blocking or Disabling Flash Player or Disabling D3D9 Accelerated Layers all also fixes the rendering problem, but with loss of HWA or Flash Player useability.

Reproducible: Always

Steps to Reproduce:
1.Enable D3D9 Accelerated Layers all, Flash Player, OOPP default setting. 
2.Go here: http://tinypic.com/ , and upload a image or go here: http://tinypic.com/view.php?pic=117z982&s=7 , a image I already uploaded.
3.
Actual Results:  
See Screenshot: http://i56.tinypic.com/2lw52t2

Expected Results:  
See Screenshot: http://i54.tinypic.com/344p0fs
Adding this "dom.ipc.plugins.enabled.npswf32.dll;false" in about:config fixes the rendering problem.
Note: Blocking or Disabling Flash Player or Disabling D3D9 Accelerated Layers all also fixes the rendering problem, but with loss of HWA or Flash Player useability.
Version: unspecified → Trunk
Summary: Tinypic.com rendering problems preventing you from retrieving [IMG] code after up loading an image when OOPP for Flash Player Enabled. → Tinypic.com rendering problems preventing you from retrieving [IMG] code after uploading an image when OOPP for Flash Player Enabled.
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/212a391d3b79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110052514
Fails:
http://hg.mozilla.org/mozilla-central/rev/bdbef533364f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110081923
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=212a391d3b79&tochange=bdbef533364f
Blocks: 596451
blocking2.0: --- → ?
Component: General → Plug-ins
Keywords: regression
Product: Firefox → Core
QA Contact: general → plugins
Target Milestone: --- → mozilla2.0
This has been happening to me as well for quite some time.
Do any errors appear in the error console? This is probably a dup of bug 601064.
(In reply to comment #3)
> Do any errors appear in the error console? This is probably a dup of bug
> 601064.
No error in Error console.

FYI, If I removed wmode="transparent" property from embed tag, the issue was gone.
( wmode="transparent" property is added by script tag of the page).
Jim, can you look into this regression? Bsmedberg, I'm marking this a blocker due to it being a regression, feel free to change the blocking status if you disagree, or dupe this etc as appropriate.
Assignee: nobody → jmathies
blocking2.0: ? → betaN+
Looks like another alpha blending problem. Let's see what gets fleshed out in bug 611698.
What *exactly* is the problem? From the screenshots, I thought it was that the "embed this video" text was not filled in. Is it a graphical glitch instead?
(In reply to comment #7)
> What *exactly* is the problem? From the screenshots, I thought it was that the
> "embed this video" text was not filled in. Is it a graphical glitch instead?

The text in the yellow text edits is missing. You can still copy paste it though, so it's there, it's just not rendered properly.
(This probably doesn't need betaN status. It's easy to reproduce and verify.)
Depends on: 611698
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [softblocker]
This seems to have been fixed by tinypic. Anyone still seeing this?
WFM on
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110110 Firefox/4.0b9pre ID:20110110160729
fixed by the vendor.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
I have confirmed that this bug has returned on Firefox 4 beta 10 and the latest Nightly Build 20110126 Firefox/4.0b11pre http://hg.mozilla.org/mozilla-central/rev/e0fc18b3bc41 both tested on fresh installs with new profiles.

More reports of this bug returning here: http://forums.mozillazine.org/viewtopic.php?f=23&t=2085851
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
It was fixed by landing of bug 628745.
http://hg.mozilla.org/mozilla-central/rev/8149e1a06476
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110125
Firefox/4.0b11pre ID:20110126103957
Depends on: 628745
Fresh clean Beta 10 profile: http://i53.tinypic.com/260385u.jpg

Fresh, clean Beta 9 Profile: http://i53.tinypic.com/1zof9ft.jpg
(In reply to comment #14)
> It was fixed by landing of bug 628745.
> http://hg.mozilla.org/mozilla-central/rev/8149e1a06476
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110125
> Firefox/4.0b11pre ID:20110126103957

I can confirm, that the Hourly Build http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1296067197/ containing the landing of bug 628745 fixed this bug 613406.

Anyone else want to confirm before I change this bugs Status to RESOLVED?
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110127 Firefox/4.0b11pre ID:20110127030333 

All is well with TinyPic for me.
Changed Status to RESOLVED due to Comment 16
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → WORKSFORME
WFM is latest nightly.
We no longer use any rounded rect clips in FrameLayerBuilder on this page.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.