Open Bug 613534 Opened 9 years ago Updated 9 years ago

Reftest harness should be more helpful when a file is missing ("timed out waiting for onload to fire" is misleading for that case)

Categories

(Testing :: Reftest, defect)

defect
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: dholbert, Unassigned)

Details

Right now, if a file is missing (or mistyped in the reftest manifest), we generate this output:

REFTEST TEST-START | file:///home/cltbld/talos-slave/mozilla-central_fedora_test-crashtest/build/reftest/tests/layout/svg/crashtests/612662-1.html
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/mozilla-central_fedora_test-crashtest/build/reftest/tests/layout/svg/crashtests/612662-1.html | timed out waiting for onload to fire

I'm filing this bug on providing a more helpful error-message for this situation - e.g. "file not found" - since otherwise, it looks like the test just timed out (which tests sometimes do).
Summary: Reftest harness should be more helpful when a file is missing → Reftest harness should be more helpful when a file is missing ("timed out waiting for onload to fire" is misleading for that case)
Sort of, though this bug was filed 4 months earlier, so if anything that bug would be a dupe of this one.

I'm guessing you meant to say "Duplicate of bug 523864?", though, based on your last comment on bug 637868, and to that I would say "basically yes".  Marking.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 523864
Actually, I'm not entirely sure about the dupe-marking I did in Comment 2 -- bug 523864 seems to be about wanting reftests to *continue* after a file-not-found, and I think that works correctly now.

This bug here is about wanting reftests to better-report a file-not-found.  Un-duping.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.