Closed Bug 613563 Opened 11 years ago Closed 11 years ago

Add close button to popup notifications

Categories

(Toolkit :: XUL Widgets, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 615315

People

(Reporter: randy.steer, Assigned: Margaret)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

When a saved password is changed, the new interface pops up what looks like a giant tool-tip asking if the changed password should be saved.

1.  The pop-up has only one button: "Save changed password".  There's now way to tell it no, and there's no way to manually close the pop-up.  It eventually goes away, but it stays there, covering part of the website, for quite a while.  Very annoying.  Every question/dialog that offers a "yes" option needs to offer a "no" option as well.

2.  The pop-up is much more intrusive than the way FF 3.6 and previous versions ask the same question.  I like the old way, and don't like big white dialog-balloons popping up on the screen.

Reproducible: Always

Steps to Reproduce:
1.  Change any saved password on a web page.
2.  Same thing probably happens with new passwords too -- haven't signed up to any new sites lately.
3.
This was mentioned at a recent UX meeting, but it wasn't discussed extensively. I don't think we currently want to implement this change, but I'm cc'ing Alex Faaborg because he has been leading UX decisions about these notifications.
Status: UNCONFIRMED → NEW
Component: General → Password Manager
Depends on: 567814
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Toolkit
QA Contact: general → password.manager
Hardware: x86 → All
Version: unspecified → Trunk
A lot of people are writing in that they feel they are being forced to click yes (it is click outside to close).  Click outside to close is considerably more efficient, since there is no mouse distance, however we need to make this more obvious.  Things we are working on include:

-adding a not now option in the drop down menu, with keyboard shortcut style text indicating that the user can click outside to close
-adding a first run message directly on the dialog indicating that it is click outside to close
-making the dialog partially transparent to indicate that is is more ephemeral than a modal dialog
-having the dialog animate back to its anchor to indicate that closing is not "no" but is actually "not yet"
-(possibly) adding a very small close button to the dialog for a primary UI target of "not yet"
(In reply to comment #2)
> Click outside to close is considerably more efficient...
> -adding a not now option in the drop down menu...
> text indicating that the user can click outside to close...

Clicking outside is not intuitive.  It's also not always as simple as it may seem, because on many websites there's a lot of "active area" with ads and things that the user DOESN'T want to click.  

Finding a suitable place to click where it won't do anything MIGHT be mechanically more efficient (depending on where the mouse pointer it), but probably wouldn't save any TIME in many cases, because it would require thinking about where it's safe to click, vs. clicking a button that you know will do what you want.

You can always keep the "click outside" behavior even if there's ALSO a "No" button.  People could do whichever seems easiest to them.

Adding drop-down options is inefficient -- using them requires TWO CLICKS (or click, hold, and drag), vs. just clicking a button that does what you want.  Look at what camera designers have been doing -- adding MORE BUTTONS that provide direct controls, vs. making users wade through "menu hell".

Analogy:  Would you like to go to vote on a referendum and see a ballot that only has one choice marked on it -- "Yes"?  

Someone might tell you later that if you had submitted the ballot without selecting anything, that would count as a "no", but wouldn't you be thinking, "Idiots!  They should just put a "No" option on the ballot!"?
This bug should apply to all popup notifications, not just the remember password notification.

At the UX meeting, Alex decided we should add a close button to the popup notifications. I'm requesting blocking because this is an important part of the notification experience, and it will address the negative feedback we've been hearing about dismissing these notifications.

Alex, what do you think this button should look like?
blocking2.0: --- → ?
Component: Password Manager → XUL Widgets
QA Contact: password.manager → xul.widgets
Summary: The pop-up "Save change to password?" dialog needs a "No" or "Close" option → Add close button to popup notifications
Margaret, thank you!  Yes, my comments reflect a general principle for UX design.

You asked Alex about what the new button should look like, but I'll put in my two cents: "No, not this time".

Most pop-ups are asking yes/no about a particular instance, so that type of phrase would be appropriate most of the time.  There are some instances where a third, "Never" or "No, don't ask again" button would also be appropriate, but there are probably a limited number of those.
Let's go with the same icon we use for tab close, sidebar close, and find bar close, aligned in the upper right corner.  The goal is to provide a clear path without diminishing the message of the dialog (which can be inferred by only reading the singular action button).
Are you suggesting NOT having a "not this time" button that's *equal* to the "yes" button?

It almost seems like you're relying on information theory to decide that something doesn't need to be said (i.e. an option doesn't have to be offered) because a series of logical deductions would leave only one possible unstated meaning.  That doesn't make a friendly interface.

"Easy" means the user doesn't have to spend time drawing inferences or following chains of deductive reasoning -- he just has to click on a choice.

[Yes]  [No]
[Yes]  [Not now, maybe later]  [Never]
[Vanilla]  [Chocolate]  [Strawberry]  [Neapolitan]

(Information theory might suggest that if an ice-cream shop menu lists vanilla, strawberry, and Neapolitan, an astute customer could infer that chocolate is also available, but I don't think customers would find that very helpful!)

Also note that the pop-up we're talking about (and probably most others) has plenty of space for a "no" button. In fact, it looks a little weird and naked with only the "yes" button sitting in a big white space.
Attached patch patchSplinter Review
I still need to test this in Linux (updating my build now), but gnomestripe may not need the same negative margins as the other themes, since there are no arrow panel styles adding padding to the panel.
Assignee: nobody → margaret.leibovic
Attachment #493129 - Flags: review?(gavin.sharp)
Attached image screenshot
(Ignore the fact that the "Learn More..." link is misaligned on OSX. That will be fixed elsewhere.)
Attachment #493130 - Flags: ui-review?(faaborg)
(In reply to comment #7)

> "Easy" means the user doesn't have to spend time drawing inferences or
> following chains of deductive reasoning -- he just has to click on a choice.

Except that choices have a cost. See http://en.wikipedia.org/wiki/Hick%27s_law

But this is offtopic for here -- if you want to argue for adding more buttons, please file a separate bug or take it to the news groups. This bug is for a very specific and focused change: adding an [X] close button.
> But this is offtopic for here -- if you want to argue for adding more buttons,
> please file a separate bug ... This bug is for a very specific and focused
> change: adding an [X] close button.

I guess you haven't looked to see who started this bug -- I did.  If you want to be technical, discussion of an "x" (close) button is off-topic, and you might want to report it as a separate bug.  (Although one discussionn for all fixes to the same dialog seems efficient to me.)  

I specifically said in the original bug report that the "yes" button needed a "no" button to go with it:

     "... Very annoying.  Every question/dialog that offers a "yes" option 
      needs to offer a "no" option as well."

I still stand by that.  You are PRETENDING to give the user a choice if you present a dialog that has only one button.  Either let the user say "yes" or "no", or don't bother to present a dialog at all.
>If you want
>to be technical, discussion of an "x" (close) button is off-topic, and you
>might want to report it as a separate bug.

I'm breaking this work off into two more specific bugs:

Bug 615315 - Add a small close button to all doorhanger notifications and panels
Bug 615318 - Add a "not now" choice to all doorhanger notification split buttons

>You are PRETENDING to give the user a choice if you
>present a dialog that has only one button.

It isn't a dialog, it's a panel.  If it were a forced choice modal dialog, I can see how people might feel this way.  But just because a lot of the old UI primitives (like modal dialog boxes) were invented by developers who wanted to treat users like they were themselves linearly executing code, doesn't mean we have to do that forever.
Attachment #493129 - Flags: review?(gavin.sharp)
Attachment #493130 - Flags: ui-review?(faaborg)
blocking2.0: ? → ---
This was fixed in bug 615315.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 615315
You need to log in before you can comment on or make changes to this bug.