pluginreg.dat rewritten on plugins list construction, even if there are no changes

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: sgreenlay, Assigned: sgreenlay)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(2 attachments)

(Assignee)

Description

7 years ago
In http://hg.mozilla.org/mozilla-central/rev/ced813e0209d we moved *aPluginsChanged = PR_TRUE; In it's new location, it is marked TRUE every time a plugin tag is added. This means that when we initially build the plugins list, it is being marked as having changed, even if there is no difference from pluginreg.dat. aPluginsChanged is used to determine when to rewrite pluginreg.dat, so we are rewriting it every time we create the plugin list.
(Assignee)

Comment 1

7 years ago
Created attachment 492010 [details] [diff] [review]
PluginReg Rewrite Fix (v1.0)
Assignee: nobody → sgreenlay
Status: NEW → ASSIGNED
Attachment #492010 - Flags: review?(joshmoz)
blocking2.0: --- → ?

Comment 2

7 years ago
Comment on attachment 492010 [details] [diff] [review]
PluginReg Rewrite Fix (v1.0)

Use braces with the if statement.
Attachment #492010 - Flags: review?(joshmoz)
Attachment #492010 - Flags: review+
Attachment #492010 - Flags: approval2.0+
(Assignee)

Comment 3

7 years ago
Created attachment 492042 [details] [diff] [review]
PluginReg Rewrite Fix (v1.0) - commit message
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
(Assignee)

Comment 4

7 years ago
http://hg.mozilla.org/mozilla-central/rev/076f5ea1f94a
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Keywords: checkin-needed

Updated

7 years ago
Duplicate of this bug: 614423

Updated

7 years ago
blocking2.0: ? → betaN+
You need to log in before you can comment on or make changes to this bug.