[OOPP] Can't input chinese with scim on Flash Player 10.1

VERIFIED FIXED in mozilla2.0

Status

()

defect
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: westfarmer, Assigned: karlt)

Tracking

({inputmethod, regression})

Trunk
mozilla2.0
x86
Linux
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [softblocker], )

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; SunOS i86pc; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (X11; SunOS i86pc; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

Can't in put chinese in chat room. switch input method not avalibe in flash appliction.

Reproducible: Always

Comment 1

9 years ago
It seems works for me, I can input Japanese kanji/kana with Japanese IME (ATOK2006/MS-IME) on a Demo Meeting,
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101121 Firefox/4.0b8pre ID:20101121044503
Keywords: inputmethod

Comment 2

9 years ago
Confirmed on ubuntu 8.04, I can not input using SCIM.
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101121 Firefox/4.0b8pre ID:20101121031805

Maybe this is Linux specific problem.

Comment 3

9 years ago
If I set dom.ipc.plugins.enabled to false I can input with IME.
Component: Extension Compatibility → Plug-ins
OS: Solaris → Linux
Product: Firefox → Core
QA Contact: extension.compatibility → plugins
Target Milestone: --- → mozilla2.0

Comment 4

9 years ago
Duplication of  Bug 573280?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Can't input chinese in bigbluebutton → [OOPP]Can't input chinese in bigbluebutton
Reporter

Updated

9 years ago
Severity: normal → critical
Component: Plug-ins → Extension Compatibility
OS: Linux → OpenSolaris
Priority: -- → P2
Product: Core → Firefox
Target Milestone: mozilla2.0 → ---
Version: unspecified → Trunk
Reporter

Comment 5

9 years ago
maybe a specific problem(In reply to comment #2)
> Confirmed on ubuntu 8.04, I can not input using SCIM.
> Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101121 Firefox/4.0b8pre
> ID:20101121031805
> 
> Maybe this is Linux specific problem.

Agree you , my system is opensolaris/x86, I think problem from gnome or flash plugin
Reporter

Comment 6

9 years ago
(In reply to comment #3)
> If I set dom.ipc.plugins.enabled to false I can input with IME.

Yes, you are right. I have confirmed on my system. thanks a lot.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Reporter

Updated

9 years ago
Resolution: WORKSFORME → INVALID

Comment 7

9 years ago
dom.ipc.plugins.enabled=false is not default value.
This is OOPP bug. REOPENED.
Status: RESOLVED → REOPENED
Component: Extension Compatibility → Plug-ins
Product: Firefox → Core
Resolution: INVALID → ---
Target Milestone: --- → mozilla2.0

Updated

9 years ago
Severity: critical → normal
blocking2.0: --- → ?
Priority: P2 → --

Updated

9 years ago
OS: OpenSolaris → Linux
Karl, is this something you could look into?
Assignee: nobody → karlt
blocking2.0: ? → betaN+
Keywords: regression
Assignee

Comment 9

9 years ago
GTK_IM_MODULE=multipress (keypad numbers -> ascii chars) seems to work as expected in a bigbluebutton chat room.
I'll have to install SCIM and remind myself how to use it.

Updated

9 years ago
Whiteboard: [softblocker]
(In reply to comment #4)
> Duplication of  Bug 573280?

Yes, you must be right.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 573280
Assignee

Comment 11

8 years ago
Bug 573280 describes a problem with ibus because ibus tries to workaround the GTK API by dispatching duplicate synthetic events to the app.

This bug should be assumed different unless there is reason to believe that scim is trying to use the same quirks.
Summary: [OOPP]Can't input chinese in bigbluebutton → [OOPP]Can't input chinese with scim in bigbluebutton
(In reply to comment #11)
> This bug should be assumed different unless there is reason to believe that
> scim is trying to use the same quirks.

Ah, I see. I'll check it. Reopening until then.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
It seems that there is no IM context in Flash Player or the IM context never gets focus. The former is wrong because iBus + Flash Player 10.1 works fine. So, this fact means Flash Player 10.1 has IM context and they set focus to the context correctly. If so with SCIM, I guess that SCIM failed something when gtk_im_focus_in() is called or it's handling key event. When SCIM gets focus, it starts snooping all key events until gtk_im_focus_out() is called. However, I cannot turn on/off from keyboard, I think this means the key event doesn't reach the handling point in IM.
> I cannot turn on/off from keyboard
I cannot turn on/off IM from keyboard
karlt:

Is IM of GTK running in an independent process? I.e., Are IM for Firefox and IM for plugin-container same one process and do the client application and IM process communicate? On Windows, IME is running in the client application's process. If I understand as so for gtk2, I cannot understand the source code of SCIM...
Assignee

Comment 16

8 years ago
AIUI browser and plugin-container processes communicate independently with GTK.
However depending on the IM, the GTK IM may communicate with a single external process.  I suspect this is the case with SCIM.
Assignee

Comment 17

8 years ago
To try to clarify.  A GTK IM module is used in both browser and plugin, but that module can do what it likes.  I think the SCIM module talks to a global process.
Thanks, then, I understand the static variables usage.
I found a bug report of this bug in SCIM bug tracker too.
https://sourceforge.net/tracker/?func=detail&aid=3034599&group_id=108454&atid=650539

I installed scim to Ubuntu 10.10, then, I *can* input Japanese text with SCIM and Flash Player 10.1. I'll check it on Ubuntu 9.10 and 10.4. Something might be fixed after Ubuntu 9.4. (I can reproduce this bug on Ubuntu 9.4)

I used SCIM by following command:

GTK_IM_MODULE=scim firefox
I can reproduce this bug on Ubuntu 10.4, but not reproduce on Ubuntu 10.10.

The version of each related components are:

                               Ubuntu 10.4                    Ubuntu 10.10
scim:                              1.4.9-2                         1.4.9-5
scim-anthy:                        1.2.7-1                         1.2.7-3
scim-bridge-agent:         0.4.16-2ubuntu3                  0.4.16-2ubuntu
scim-bridge-client-gtk:    0.4.16-2ubuntu3                  0.4.16-2ubuntu
scim-gtk2-immodule:                1.4.9-2                         1.4.9-5
scim-modules-socket:               1.4.9-2                         1.4.9-5
libgtk2.0-0:               2.20.1-0ubuntu2                 2.22.0-0ubuntu1
flashplugin-installer: 10.1.102.65ubuntu0.10.04   10.1.102.65ubuntu0.10.10

I suspect the difference of gtk2 version.

However, anyway, I think this bug may have been fixed by something which is out of our scope.
Summary: [OOPP]Can't input chinese with scim in bigbluebutton → [OOPP] Can't input chinese with scim on Flash Player 10.1
Let's resolve it, then.
Status: REOPENED → RESOLVED
blocking2.0: betaN+ → -
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
I could reproduce this problem on Ubuntu 10.04 too. But the problem is gone with backported scim from Ubuntu10.10, so I think the problem was an scim bug which has been fixed in scim-1.2.7-3 (in Ubuntu 10.10).

westfarmer, contact developers of opensolaris, please.
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.