Closed Bug 613998 Opened 9 years ago Closed 9 years ago

Wake Mac from sleep, browser goes 'offline' and force quit required (event loop spinning forever)

Categories

(Firefox :: General, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 614958
Firefox 4.0b8

People

(Reporter: simon.bugzilla, Assigned: ehsan)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101121 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101121 Firefox/4.0b8pre

When waking Mac up from sleep, browser does not load any web pages, in fact there is zero net activity from the browser. Quitting the browser (cmd+q) or from menu bar causes app to hang, force quit is required (could be another bug).

Reproducible: Always
I've noticed this happening the last couple days. A wild guess is the TCP SYN change.. bug 592284?
Status: UNCONFIRMED → NEW
blocking1.9.2: --- → ?
Ever confirmed: true
Attached image stuck offline
I sampled the process when Firefox wouldn't let me quit. But some reason I can't save the output. I've got just a screenshot of it for now.
blocking1.9.2: ? → ---
blocking2.0: --- → ?
20 ok? http://hg.mozilla.org/mozilla-central/rev/baa6cc2f72e4
21 bad http://hg.mozilla.org/mozilla-central/rev/be4b69a4babf

Build from 1121 definitely is bad, but because I don't have a deterministic STR, 20 seems good so far.

Doing File -> Work Offline can trigger this as well as it eventually calls SetOffline:

nsIOService::SetOffline(int)
 nsSocketTransportService::Shutdown()
  nsThread::Shutdown()
   NS_ProcessNextEvent_P(nsIThread*, int)
    nsThread::ProcessNextEvent(int, int*)
     nsEventQueue::GetEvent(int, nsIRunnable**)
      PR_Wait
       PR_WaitCondVar
        _pthread_cond_wait
         __semwait_signal

I don't know what exactly leads up to SetOffline spinning forever. A fresh restart doesn't trigger it, but after some browsing, it'll go bad when I select Work Offline.
Summary: Wake Mac from sleep, browser goes 'offline' and force quit required. → Wake Mac from sleep, browser goes 'offline' and force quit required (event loop spinning forever)
I think my patch in bug 614286 addresses this problem completely.
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Depends on: 614286
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
OS: Mac OS X → Windows XP
Resolution: --- → DUPLICATE
Duplicate of bug: 614286
Resolution: DUPLICATE → FIXED
Whiteboard: [fixed by bug 614286]
Target Milestone: --- → Firefox 4.0b8
So, the symptom in comment 0 is not exactly that of bug 614286 (the thing which happens after trying to quit is).

I'm not still convinced that this is the exact same issue as bug 614286, so I'll reopen this for now and will try to reproduce this once bug 614286 is fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [fixed by bug 614286]
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614958
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.