Direct3D 9 (non-ex) Devices cannot be reset

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: bas.schouten, Assigned: bas.schouten)

Tracking

unspecified
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta8+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 492482 [details] [diff] [review]
Clear and recreate VertexBuffer on device reset

For a while now we've had D3D9 devices use a VertexBuffer in D3DPOOL_DEFAULT. This is fine but it means the buffer needs to be released and recreated when a device reset is performed on a non D3D9-ex device (for example after screenlock), otherwise the device reset will fail and we will consider the device lost beyond hope and recreate all layer managers.
Attachment #492482 - Flags: review?(jmuizelaar)
(Assignee)

Comment 1

8 years ago
This is a big problem for Windows XP.
blocking2.0: --- → ?
(Assignee)

Comment 2

8 years ago
Created attachment 492489 [details] [diff] [review]
Clear and recreate VertexBuffer on device reset v2

Add missing return true.
Assignee: nobody → bas.schouten
Attachment #492482 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #492482 - Flags: review?(jmuizelaar)

Comment 3

8 years ago
sounds like we need to change this from nominated for 2.0 to blocking beta8 to reduce the volume of the #1 top crash on trunk (bug 611597).
Can we just used D3DPOOL_MANAGED to avoid loosing the vertex buffer on device reset?

Updated

8 years ago
blocking2.0: ? → beta8+
Attachment #492489 - Flags: review+
(Assignee)

Comment 5

8 years ago
http://hg.mozilla.org/mozilla-central/rev/9ecae0a45ab8
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
No longer blocks: 611597
Duplicate of this bug: 611597

Updated

8 years ago
Depends on: 614762

Updated

8 years ago
Blocks: 611597

Updated

8 years ago
Depends on: 614771
(Assignee)

Updated

8 years ago
Duplicate of this bug: 604647
You need to log in before you can comment on or make changes to this bug.