Closed Bug 614228 Opened 9 years ago Closed 9 years ago

[SeaMonkey] Windows bustage in nsUrlWidget after bug 581596 landing

Categories

(Core :: Widget, defect, blocker)

defect
Not set
blocker

Tracking

()

RESOLVED FIXED
mozilla2.0b8
Tracking Status
blocking2.0 --- final+

People

(Reporter: kairo, Assigned: mwu)

References

Details

Attachments

(1 file)

make[6]: Entering directory `/e/builds/slave/comm-central-trunk-win32-debug/build/objdir/suite/browser/src'
nsUrlWidget.cpp
d:/mozilla-build/python25/python2.5.exe -O e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/build/cl.py cl -FonsUrlWidget.obj -c -D_HAS_EXCEPTIONS=0 -I../../../mozilla/dist/stl_wrappers  -DMOZ_SUITE=1 -DOSTYPE=\"WINNT5.2\" -DOSARCH=WINNT  -I/e/builds/slave/comm-central-trunk-win32-debug/build/suite/browser/src -I. -I../../../mozilla/dist/include -I../../../mozilla/dist/include/nsprpub  -Ie:/builds/slave/comm-central-trunk-win32-debug/build/objdir/mozilla/dist/include/nspr -Ie:/builds/slave/comm-central-trunk-win32-debug/build/objdir/mozilla/dist/include/nss        -GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800  -DDEBUG -D_DEBUG -DTRACING -Zi -MDd           -FI ../../../comm-config.h -DMOZILLA_CLIENT /e/builds/slave/comm-central-trunk-win32-debug/build/suite/browser/src/nsUrlWidget.cpp
nsUrlWidget.cpp

e:\builds\slave\comm-central-trunk-win32-debug\build\objdir\mozilla\dist\include\nsStringFwd.h(49) : fatal error C1189: #error :  Internal string headers are not available from external-linkage code.

make[6]: Leaving directory `/e/builds/slave/comm-central-trunk-win32-debug/build/objdir/suite/browser/src'
make[5]: Leaving directory `/e/builds/slave/comm-central-trunk-win32-debug/build/objdir/suite/browser'
make[4]: Leaving directory `/e/builds/slave/comm-central-trunk-win32-debug/build/objdir/suite'
make[3]: Leaving directory `/e/builds/slave/comm-central-trunk-win32-debug/build/objdir'
make[2]: Leaving directory `/e/builds/slave/comm-central-trunk-win32-debug/build/objdir'
make[6]: *** [nsUrlWidget.obj] Error 2


This happens on Windows SeaMonkey builds since bug 581596 landed. Standard8 says this on IRC:

<Standard9> here's your regression: http://hg.mozilla.org/mozilla-central/rev/674eb3bc24a5
<Standard9> well
<Standard9> maybe
<Standard9> yes it is
<Standard9> line 7.7
<Standard9> the #include "nsString.h"
<Standard9> in theory that should be #include "nsStringGlue.h", but at a quick glance, I'm not sure that's the right thing there
<Standard9> basically the mozilla-central code there is assuming internal API
<Standard9> whereas suite is using the interface from external API
Severity: normal → blocker
Version: unspecified → Trunk
This appears to work on Linux64 and Android builds. Can someone confirm that it fixes Seamonkey?
Assignee: nobody → mwu
Attachment #492691 - Flags: review?(ted.mielczarek)
Attachment #492691 - Flags: review?(benjamin)
> Created attachment 492691 [details] [diff] [review]
> Switch to nsStringGlue.h
> 
> This appears to work on Linux64 and Android builds. Can someone confirm that it
> fixes Seamonkey?

This allows me to build SeaMonkey trunk on Windows7 using VS2008SP1.
Attachment #492691 - Flags: feedback+
Status: NEW → ASSIGNED
blocking2.0: --- → ?
Flags: in-testsuite-
(In reply to comment #3)
> sent to try: http://hg.mozilla.org/try/rev/f40f8088baac

And this passed try... would be GREAT to get a review in before weekend ends.
Landed http://hg.mozilla.org/mozilla-central/rev/02d4531f0d55 with a=shaver over irc. and "Post-landing-review is just fine" per shaver
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1290818580.1290824258.22489.gz
WINNT 5.2 comm-central-trunk build on 2010/11/26 16:43:00
turned green :-)
Component: Build Config → Widget
Product: SeaMonkey → Core
QA Contact: build-config → general
Summary: Windows bustage in nsUrlWidget after bug 581596 landing → [SeaMonkey] Windows bustage in nsUrlWidget after bug 581596 landing
Target Milestone: --- → mozilla2.0b8
[This is also needed for true mail-on-xulrunner builds because nsMessengerWinIntegration.cpp contains an nsCOMPtr<nsIWidget>]
Fixed eh?
Status: ASSIGNED → RESOLVED
blocking2.0: ? → final+
Closed: 9 years ago
Resolution: --- → FIXED
I was leaving open due to pending-review [even though this landed]. roc, if you want to mark it, and/or disagree please just go ahead and close it [again].
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Whiteboard: [re-opened pending Post-landing-review]
Comment on attachment 492691 [details] [diff] [review]
Switch to nsStringGlue.h

I really am not that knowledgeable about the string APIs.
Attachment #492691 - Flags: review?(ted.mielczarek)
Attachment #492691 - Flags: review?(benjamin) → review+
Blocks: 581596
Status: ASSIGNED → RESOLVED
Closed: 9 years ago9 years ago
No longer depends on: 581596
Resolution: --- → FIXED
Whiteboard: [re-opened pending Post-landing-review]
You need to log in before you can comment on or make changes to this bug.