Regression: Awesomebar suggestions do not update while typing [HWKB]

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
--
major
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({regression})

Trunk
All
Android
regression

Details

(Whiteboard: [hkb])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
Steps to reproduce:
1. Open the hardware keyboard.
2. Tap in the awesomebar and start typing.

Expected results: Awesomescreen results update as you type.

Actual results: Awesomescreen results update only for the first character typed, or whenever you press backspace.

Tested on local trunk Android build.
(Assignee)

Updated

7 years ago
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0b3+
Assignee: nobody → mbrubeck
Whiteboard: [hkb]
(Assignee)

Comment 1

7 years ago
The "keydown" events are not sent to Gecko, because mKeyListener.onKeyDown returns "true" in GeckoApp::onKeyDown.

Comment 2

7 years ago
(In reply to comment #1)
> The "keydown" events are not sent to Gecko, because mKeyListener.onKeyDown
> returns "true" in GeckoApp::onKeyDown.

Of course, keydown events aren't the only thing that can trigger awesomebar updating. After all, almost no key events are sent when typing with many soft keyboards. The difference is that the text events during softkb composition are sent during composition, while the text events sent through the hardkb listener are sent without composition. Wonder if that makes the difference. Maybe jchen knows.
(Assignee)

Comment 3

7 years ago
Created attachment 493035 [details] [diff] [review]
WIP

mwu suggested starting and stopping coposition to force an update.  Here's an implementation of that suggestion.  It fixes this bug, but I'm not sure if it's the correct way to do it.
(Assignee)

Comment 4

7 years ago
Created attachment 493051 [details] [diff] [review]
patch

Here's a better patch, with much help from jchen.  Makes sure that the text event happens between composition begin/end events.
Attachment #493035 - Attachment is obsolete: true
Attachment #493051 - Flags: review?(blassey.bugs)
Attachment #493051 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 5

7 years ago
http://hg.mozilla.org/mozilla-central/rev/a4af96fd1ce2
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101129 Namoroka/4.0b8pre Fennec/4.0b3pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.