Closed Bug 614353 Opened 10 years ago Closed 9 years ago

Pages that are not as tall as the viewport are rendered with a grey area at the bottom

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(fennec-)

VERIFIED FIXED
Tracking Status
fennec - ---

People

(Reporter: nhirata, Assigned: mbrubeck)

Details

Attachments

(8 files)

Attached image screenshot
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101123 Firefox/4.0b8pre Fennec/4.0b3pre
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101123 Firefox/4.0b8pre Fennec/4.0b3pre

1. place the device in portrait mode
2. go to www.irs.gov

Expected: the web page fits to the device accordingly
Actual: there's a large space at the bottom
flagging for blocking.  pages should draw out in portrait mode
tracking-fennec: --- → ?
Attached image desktop screenshot
Not a bug - this site is actually supposed to have a grey background outside of the main content area.  See the attached screenshot from a desktop browser, for example.
Assignee: nobody → mbrubeck
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
I disagree.  look at the two sites loaded on fennec vs android stock.  Android stock will size the content correctly and leave out the excess layout, while fennec loads the whole thing.
Fennec screenshot of same site.
(In reply to comment #4)
> I disagree.  look at the two sites loaded on fennec vs android stock.  Android
> stock will size the content correctly and leave out the excess layout, while
> fennec loads the whole thing.

www.irs.gov is a bad example then, because the stock Android Browser renders it exactly the same as Fennec.  Reopening with a new summary.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: www.irs.gov loaded in portrait mode has a large grey area at the bottom of the page → Pages that are not as tall as the viewport are rendered with a grey area at the bottom
tracking-fennec: ? → 2.0+
Attached patch patchSplinter Review
Status: REOPENED → ASSIGNED
Hardware: ARM → All
Whiteboard: [has-patch]
Attachment #503926 - Flags: review?(mark.finkle)
Attachment #503926 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/97589e987937
Status: ASSIGNED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
I can still reproduce it :

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:2.2a1pre) Gecko/20110406 Firefox/4.2a1pre Fennec /4.1a1pre 

Device: Motorola Droid 2 (Android 2.2)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached image The actual result
tracking-fennec: 2.0+ → 6+
Whiteboard: [has-patch] → [needs additional patch?]
tracking-fennec: 6+ → 7+
Matt - what direction are we going to take for this bug?
First we need to investigate to find out what's actually happening in the cases where this is broken.  I'm not sure but I suspect it might be related to the problems in bug 654122; if so, finishing that patch might fix this bug.
Depends on: 654122
I'm able to reproduce this issue on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/20110620
Firefox/7.0a1 Fennec/7.0a1
Device: Motorola Droid 2
OS: Android 2.2

Steps to reproduce:
1. Open Fennec app (device should be switch to portrait)
2. Browse to http://dnt.mozilla.org
3. After the page is loaded completely, reload the page

Actual result: At step 2, the bottom side of the page is white, but after step 3 there will be lots of checkerboards.
Attached image screenshot
(In reply to comment #13)

Please file a new bug for that (although I think I've, I'm going to close this bug, it has become a big mess.
A patch was attached to this bug and went in, so I'm marking it fixed.

The issue for http://www.irs.gov/ is fixed, I can't seem to find any issue with it.

I can see the issue for http://www.theanimenetwork.com/ but when I change my user agent to the Android browser, the it renders the same as the stock Android browser, so that is most likely a tech evangelism bug.
No longer depends on: 654122
Whiteboard: [needs additional patch?]
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → FIXED
tracking-fennec: 7+ → -
> The issue for http://www.irs.gov/ is fixed, I can't seem to find any issue with it.

The issue is not fixed. I see it in a nightly. Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #16)
> > The issue for http://www.irs.gov/ is fixed, I can't seem to find any issue with it.
> 
> The issue is not fixed. I see it in a nightly. Reopening.

www.irs.gov never had any rendering bug; the gray background on that site is part of the site's design.  See https://bugzilla.mozilla.org/show_bug.cgi?id=614353#c3

Let's open new bugs for any specific issues that exist; this bug has clearly become too confusing.  :P
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Attached image Screenshot - Nightly
Still there is a difference between Android Stock browser and Fennec for http://www.theanimenetwork.com/ as you can see in the attached screenshot. Imo it seems that it's a little bit worse than Tony's screenshot. Reopening bug

--
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110911
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
As I said in comment 17, please open new bugs for any current issues that exist.  The issue in this bug (checkerboard below the bottom of the content on certain pages) is fixed.

For what it's worth, the rendering of theanimenetwork.com in attachment 559835 [details] looks fine to me; it is the same as the rendering in desktop Firefox in a 980-pixel-wide window.  It looks like the stock browser chooses a different window width, but either rendering is valid.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
I've performed the reproducing steps from comment #13 on the latest Nightly build and there are no more checkerboards on the bottom of the page. I'll mark this bug as verified fixed.

--
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110911
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.