Closed Bug 614417 Opened 9 years ago Closed 9 years ago

no Drag Feedback on Item using setDragImage

Categories

(Core :: DOM: Drag & Drop, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0

People

(Reporter: xtc4uall, Unassigned)

References

()

Details

(Keywords: regression, testcase)

* open URL (Testcase of Bug 614386)
* drag the green Item around

actual:
while dragging only Mouse Drag Indicator is shown

expected:
green Item shold be shown as Drag Feedback, too

Regressed within:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a4fea9526b7b&tochange=1a107c990c89
=> Candidate Bugs: Bug 574596/Bug 556432

Tested on WinXP using Build built from http://hg.mozilla.org/mozilla-central/rev/4b9ba5049e66

Works as expected on Google Chrome 9.0.583.0 (and Fx 3.6.x, of course).
It also happens on Mac (10.6.5) and Linux (10.10) on the latest nightly.
OS: Windows XP → All
The Reporter of Bug 614386 found this Issue by himself and filed a Report on his own before i saw it.
Duping this against his Report since there's a better Testcase over there, too :-).
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614397
Arrg, reopening, since *this* Testcase shows a true Regression against Fx 3.6 Behavior when dragging an Item (with position: absolute) opposed to the one over in Bug 614397 ....
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
In local build,
Build from 7133f717ed2a : fails
Build from 7ca493708001 : works

So, this seems to be regressed by 7133f717ed2a	Mats Palmgren — Bug 556432 - Dragging a content selection shows non-selectable text in the drag feedback. r=roc
Blocks: 556432
blocking2.0: --- → ?
Target Milestone: --- → mozilla2.0
This got fixed along with the other Bug.
Tested with a Build built from http://hg.mozilla.org/mozilla-central/rev/ded653253911
Status: REOPENED → RESOLVED
blocking2.0: ? → ---
Closed: 9 years ago9 years ago
Depends on: 614397
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.