Alerts should be content-modal, not window-modal when alert opened from Sidebar Panel

RESOLVED WONTFIX

Status

()

Toolkit
General
--
enhancement
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

Trunk
mozilla2.0
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Build Identifier: 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre ID:20101124042634

Alerts should be content-modal, not window-modal when alert open from Sidebar Panel page


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Bookmark The URL and Check "Load this bookmark in the sidebar"
3. Opeb the Bookmark in the Sidebar Panel
4. Click "Please Click to pop up Alert" to open alert box


Actual Results:
 The alert box is window-modal.

Expected Results:
 The alert box should be content-modal.

Comment 1

7 years ago
Well, which content should that alert() be modal too? 
You shouldn't make it modal to the main content, because that's not related to the sidebar. 
It would make sense to make it modal to the sidebar, but an alert() doesn't fit in there.

Only way I see is to make it modal to both sidebar and main content. I don't think this is perfect, but at least its better than being window-modal.
Sidebar is effectively deprecated, and it lacks the bits added in bug 596371 and bug 59314 to support tab-modal overlays. Not going to fix this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.