Blank thumbnail for pages opened with Google's "I'm feeling lucky" feature.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: ahoza, Assigned: mfinkle)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 493212 [details]
Screenshot

BuildID: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b8pre)Gecko/20101124 Firefox/4.0b8pre Fennec /4.0b3pre 
Device: Nokia N900

BuildID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101123 Firefox/4.0b8pre Fennec /4.0b2pre
Device: HTC Desire A8181

Steps to reproduce:

Scenario 1:

1. Start Fennec.
2. Type "personas" in URL bar and "Return"/"Go" button

Expected results:
getpersonas.com page is opened. It has a non blank thumbnail in tabs panel.

Actual results:
Blank thumbnail in tabs panel.

Also when Google finds no matches for searched string the result is the same.

Scenerio 2:

1. Start Fennec.
2. Type "qwertyuiop12345" in URL bar (or any string for which Google will find no matches)
3. Tap/Press "Return"/"Go" button 

Expected results:
Thumbnail in tab panel is not blank.

Actual results:
Thumbnail is blank
(Reporter)

Updated

8 years ago
Summary: No thumbnail for pages opened with Google's "I'm feeling lucky" feature. → Blank thumbnail for pages opened with Google's "I'm feeling lucky" feature.

Comment 1

8 years ago
this seems like a previously reported issue, but was it tile caching related?   Flagging to block for investigation, but dupeme if you find it
tracking-fennec: --- → ?
Whiteboard: dupme
Let's see if we can do something better with thumbnail generation
Assignee: nobody → mark.finkle
tracking-fennec: ? → 2.0+
I don't see any black thumbnails anymore. Can you reproduce the problem?
(Reporter)

Comment 4

8 years ago
I can still reproduce this bug, with scenario 2 using:
 
buildID: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b9pre)Gecko/20110103 Firefox/4.0b9pre Fennec /4.0b4pre 
device: Nokia N900 

and 
buildID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b9pre) Gecko/20110103 Firefox/4.0b9pre Fennec /4.0b4pre
deviceL Motorola Droid 2
(Assignee)

Updated

8 years ago
tracking-fennec: 2.0+ → 2.0-

Comment 5

8 years ago
Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre) Gecko/20110313 Firefox/4.0b13pre Fennec /4.0b6pre 
Device: HTC Desire 
OS: Android 2.2 

Blank thumbnail on Geolocation Test Webpage (http://hg.mozilla.org/qa/litmus-data/raw-file/tip/firefox/geolocation/wifi.html).
Geolocation test page is actually blank until you do something in the notification. All content is added dynamically, but we only draw the thumbnail once (when first draw fires and network activity is done). Using our current drawing method, it is expected for these thumbnails to be blank.

I'm feeling lucky searches seem to work fine for me.
wfm based on wes's comment 6
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.