Closed Bug 614793 Opened 11 years ago Closed 11 years ago

Web console window should automatically scroll to display results

Categories

(DevTools :: General, defect, P1)

x86
All
defect

Tracking

(blocking2.0 final+)

RESOLVED FIXED
Firefox 4.0b9
Tracking Status
blocking2.0 --- final+

People

(Reporter: moz.teodosia, Assigned: msucan)

References

Details

(Whiteboard: [Web-Console-Testday])

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre

When the scroll bar activates in web console, if entering a command, the window doesn't automatically scroll down so that the result can be visible.

Reproducible: Always

Steps to Reproduce:
1.Open the web console.
2.Type any commands until the scroll bar appears in the console.
3.Type any of commands: find(), typeof(), keys()
Actual Results:  
The web console window is not automatically scrolled vertically in order to see the result.

Expected Results:  
The web console window should automatically scroll to display the result.

This issue is also reproducible on Linux.
Version: unspecified → Trunk
this should have been fixed with bug 601352, but it looks like you're running a nightly so you should have that fix.
Assignee: nobody → mihai.sucan
Blocks: devtools4
Priority: -- → P1
This is a regression that I noticed on Saturday while working on bug 613642, which looks like it's caused by some shuffling of console scrolling code - not sure which patch is to be blamed. Will fix ASAP.
Depends on: 613642
This now fixed by the patch in bug 613642, with a one line fix and a mochitest.
OS: Mac OS X → All
Whiteboard: [Web-Console-Testday]
it makes more sense to include your one line patch with test in this bug rather than bundling it with an unreviewed patch. We could get that reviewed more quickly this way.
Attached patch proposed fix (obsolete) — Splinter Review
Directly asking for review, because I already got f+ from Robert, for these changes. (in bug 613642)

The fix turned out to be three lines, not exactly a one-liner, but still, it's very small.
Attachment #497509 - Flags: review?(dolske)
Status: NEW → ASSIGNED
Whiteboard: [Web-Console-Testday] → [Web-Console-Testday][patchclean:1214]
Blocks: 613642
No longer depends on: 613642
This should be blocking, because it's an annoying regression.
blocking2.0: --- → ?
blocking2.0: ? → final+
Keywords: regression
I think this may have been fixed by bug 605621? I can't reproduce, and the relevant code seems to have been refactored.
Correct. This bug is, indeed, fixed by the landing of part 1 patch from bug 605621.

Should I update the patch to only hold the mochitest? So we can have a test for this issue, in case of future regressions.
(In reply to comment #8)
> Should I update the patch to only hold the mochitest? So we can have a test for
> this issue, in case of future regressions.

Indeed - and honestly, I'd say any peer review of the test is sufficient - wouldn't block on a formal review for a test-only patch. (Do make sure it passes on all platforms, though. :)
Attached patch mochitestSplinter Review
Mochitest patch only.

Will send this through the tryserver, to make sure there are no failures.
Attachment #497509 - Attachment is obsolete: true
Attachment #497509 - Flags: review?(dolske)
No longer blocks: 613642
Whiteboard: [Web-Console-Testday][patchclean:1214] → [Web-Console-Testday][patchclean:0103]
Try server results seem to be fine.
Whiteboard: [Web-Console-Testday][patchclean:0103] → [Web-Console-Testday][patchclean:0103][checkin]
Comment on attachment 500847 [details] [diff] [review]
mochitest

wfm
Attachment #500847 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/7cf8a9f5b7e2
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [Web-Console-Testday][patchclean:0103][checkin] → [Web-Console-Testday]
Target Milestone: --- → Firefox 4.0b9
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.