Content-modal alerts not very responsive

RESOLVED DUPLICATE of bug 613714

Status

()

Toolkit
General
RESOLVED DUPLICATE of bug 613714
7 years ago
3 years ago

People

(Reporter: keegkey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre

New javascript content-modal alerts are much less responsive than before.
For example on my machine P4 2.8GHz & ati 9550 it takes approximately 1-2sec to show up modal dialog.
Whereas in ff 3.6 is almost instantaneously.

Reproducible: Always
Dupe of Bug 613714?

Updated

7 years ago
Depends on: 613714
I think the responsiveness issue comes from having to load the SVG filter to get the blur effect on the page behind the alert.

Comment 3

7 years ago
@Wes: I think the issue isn't loading SVG, but applying the blur effect. Convolution is slow (isn't it?)

But that's handled by that bug too. Thus it is a dupe.

Comment 4

7 years ago
It's slow also when you switch to tab with alert, not only when alert is shown for the first time
There are at least 2 separate issues (first prompt slow to show blur effect, slowness in switching back to a tab with prompt). Let's deal with it all in bug 613714.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 613714
You need to log in before you can comment on or make changes to this bug.