Closed Bug 614865 Opened 9 years ago Closed 9 years ago

Addon about window does not handle overflow very well

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0b8
Tracking Status
blocking2.0 --- final+

People

(Reporter: josh.tumath+bugzilla, Assigned: Unfocused)

References

()

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101125 Firefox/4.0b8pre
Build Identifier: 

If an addon has a very long title or has a lot of contributors credited, there are some issues in the addon about window that prevent all of the text from being seen. These issues can also distort the window.

To reproduce this, view the about window for Firebug and one of the Mozilla Labs Prospector addons.

Reproducible: Always
Blocks: 601022, 586066
Version: unspecified → Trunk
So you say, you don't see any scrollbars? Can you please attach a screenshot?
No longer blocks: 586066
Component: Themes → Add-ons Manager
QA Contact: themes → add-ons.manager
I do see scrollbars, but the problem is not in the scrollbars; it's in the fact that the scrollbars are in the way of the content. Sorry, I should have uploaded a screenshot in the first place.
Attachment #493408 - Attachment description: Addon with a very long name → Addon with many people credited
Ok, I see. Same on OS X for both of those extensions. Dave, something we should block on? It's not primary ui but seems to be that this window doesn't layout content very well.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
How did this behave on Firefox 3.6?
(In reply to comment #5)
> How did this behave on Firefox 3.6?

It stretched the dialog until all the text fitted. Which in some cases meant that the dialog was larger than the screen.
Attached patch Patch v1Splinter Review
Makes the addon name wrap if its too long. The icon was acting weird with max-height when the name wrapped, so its in its own container now. And a call to sizeToContent() because xul:dialog is stupid.

The weird scrolling issue with Firebug's about dialog is due to Firebug overlaying its own stylesheet for about.xul - probably in order to fix the issue described in comment 6. If you disable Firebug, and open its about dialog, you'll see that it works fine. I could potentially rename the CSS classes used in the dialog, but a better solution is for Firebug to not style the about dialog in 4.0 (or at least style in a way that doesn't break things).
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Attachment #494637 - Flags: review?(dtownsend)
Comment on attachment 494637 [details] [diff] [review]
Patch v1

>diff --git a/toolkit/mozapps/extensions/content/about.xul b/toolkit/mozapps/extensions/content/about.xul
>--- a/toolkit/mozapps/extensions/content/about.xul
>+++ b/toolkit/mozapps/extensions/content/about.xul
>@@ -54,20 +54,22 @@
>   <script type="application/javascript" src="chrome://mozapps/content/extensions/about.js"/>
>   <script type="application/javascript" src="chrome://global/content/contentAreaUtils.js"/>
> 
>   <stringbundleset id="aboutSet">
>     <stringbundle id="extensionsStrings" src="chrome://mozapps/locale/extensions/extensions.properties"/>
>   </stringbundleset>
> 
>   <vbox id="clientBox" flex="1">
>-    <hbox class="basic-info" align="center">
>-      <image id="extensionIcon"/>
>-      <vbox>
>-        <label id="extensionName" crop="end"/>
>+    <hbox class="basic-info">
>+      <vbox pack="center">
>+        <image id="extensionIcon"/>
>+      </vbox>

Not really sure that these changes are necessary are they?

Otherwise r+
Attachment #494637 - Flags: review?(dtownsend) → review+
(In reply to comment #8)
> >+    <hbox class="basic-info">
> >+      <vbox pack="center">
> >+        <image id="extensionIcon"/>
> >+      </vbox>
> 
> Not really sure that these changes are necessary are they?

Without the extra container box around the image, I had some layout issue where the parent box's height was dependent on the image's max-height. 

Could I get a blocking+ on this? (or failing that, a+?) See comment 3 for how it breaks without this patch.
blocking2.0: ? → final+
https://hg.mozilla.org/mozilla-central/rev/88fee6b520bb

Might be useful to have a Litmus test with a long-named addon.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Flags: in-litmus+
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Flags: in-litmus+ → in-litmus?
Blair, at least what I can see on OS X the scrollbars in the about window aren't shown correctly. There is no bar to drag. Is that intended?
Could you attach a screenshot?
Ah, that's Firebug's fault for breaking things. See the second part of comment 7:

> The weird scrolling issue with Firebug's about dialog is due to Firebug
> overlaying its own stylesheet for about.xul - probably in order to fix the
> issue described in comment 6. If you disable Firebug, and open its about
> dialog, you'll see that it works fine. I could potentially rename the CSS
> classes used in the dialog, but a better solution is for Firebug to not style
> the about dialog in 4.0 (or at least style in a way that doesn't break things).
Makes sense. Thanks for pointing it out. I missed that comment. Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101212 Firefox/4.0b8pre

(In reply to comment #10)
> Might be useful to have a Litmus test with a long-named addon.

Blair, the only manual test we would need here is for wrapping a long extension name? Or do we also need to verify the scrollbars?
Status: RESOLVED → VERIFIED
(In reply to comment #15)
> Blair, the only manual test we would need here is for wrapping a long extension
> name? Or do we also need to verify the scrollbars?

Just the long addon name.
(In reply to comment #16)
> Just the long addon name.

Ok. Created a sample extension for that case, which can for now be found at:
http://mozilla.hskupin.info/aom/extensions/long-name.xpi
Litmus test has been updated:
https://litmus.mozilla.org/show_test.cgi?id=10148
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.