need access keys to switch between "all" and "brief" headers

NEW
Unassigned

Status

SeaMonkey
MailNews: Message Display
17 years ago
6 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

(Depends on: 1 bug, {access})

Firefox Tracking Flags

(Not tracked)

Details

4x had this, and it was very useful.

I think it was ctrl-shift-2 and ctrl-shift-3 on linux.
Keywords: 4xp

Updated

17 years ago
QA Contact: esther → nbaca

Comment 1

17 years ago
I double checked and you're correct. Ctrl+Shift+2 displays All headers and
Ctrl+Shift+3 displays Normal headers. These shortcut keys are not referenced in
the 4.7 menu so I would have never known about this, handy.

Adding jglick to Cc: list for her input since I'm not sure if Ctrl+Shift+# will
be used for other functions.

Comment 2

17 years ago
Thanks for the info.

Hmm. Is this different on Windows? Is this a Linux only thing? On 4.x Windows: 
Ctrl+Shift+2 on Windows brings up my AB.  And Ctrl+Shift+3 does nothing.

Currently Ctrl+Shift+<number> are all available. I will add these to the 
Accelerator spec.  So is Ctrl+Shift+1 Brief Headers?
I was the one who added ctrl-shift-2 and ctrl-shift-3 to the XFE in 4.x

I assumed 4.x on on win32 had similar tricks, maybe putterman knows.

ctrl-shift-1 (really ctrl-!), which I think was rot-13 in 4.x on linux.
  

Comment 4

17 years ago
I don't know of anything on Windows.

Comment 5

16 years ago
Before adding a keyboard shortcut, we should add a menu item, so that keyboard
users can /find/ the shortcut.  I suggest adding "Brief" to the View->Headers
menu, which currently only has "All" and "Normal" options.

I think H should toggle between (Normal or All) and Brief headers.  I don't
think it's very important to be able to switch between Normal and All quickly,
since Ctrl+U works much better than View->Headers->All anyway. 
(View->Headers->All covers 90% of the message and freezes mozmail.)
Keywords: access

Comment 6

16 years ago
Please see bug 60207 for View/Headers/Brief. I posted a patch long before.

Comment 7

16 years ago
>Before adding a keyboard shortcut, we should add a menu item, so that keyboard
>users can /find/ the shortcut.  I suggest adding "Brief" to the View->Headers
>menu, which currently only has "All" and "Normal" options.

Definitely.

Updated

16 years ago
Depends on: 60207
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
Priority: P3 → --
QA Contact: nbaca → message-display

Comment 8

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 9

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 10

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 11

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 12

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 13

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Updated

6 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: EXPIRED → ---
Having shortcuts for this is a valid RFE for sure, although free keys are a very limited resource by now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.