Two minefield instances per click of launcher after first. Unresponsive instances left after a session.

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Ian H, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101123 Firefox-4.0/4.0b8pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101123 Firefox-4.0/4.0b8pre

I've been having problems with unresponsive firefox-4.0bin processes left after a browsing session that must be killed via killall in a terminal. This is recent and probably started in either todays daily update, or possibly the day before and I didn't notice it. I haven't been able to to pin down an explicit trigger. The lonmger my browsing session the more likely I am to be left with an unresponsive process afterwards.

In experimenting to try to trigger this deliberately I noted that clicking on the launcher opens two firefox instances if firefox is already running. To clarify, the first time I click on the launcher one instance of firefox opens. Clicking again opens two instances (as observed in Window List 2.30.2), one of which does not generate a window and closes after about 10-15 seconds.I am not sure if this is related to the first problem.

Launcher command is "firefox-4.0 %u"

I am using Ubuntu Lucid fully updated as of 10.45AM Saturday 27 Nov NZ time. 

Reproducible: Always

Steps to Reproduce:
1.Click on launcher to open minefield.
2.Click on launcher more times.
Actual Results:  
1. After first click observe one instance in window list
2. Each subsequent click opens two new instances on window list, a real one, and one that does not generate a window and closes after 10-15 seconds.. 

Leftover processes are also being observed after a session which have to be killed via " killall firefox-4.0bin " from a terminal. However I have been unable to trigger these reliably. I don't know if this is related.

Expected Results:  
Each click of the launcher should generate one new instance of firefox. 

I should not have to "killall firefox-4.0bin" after a browsing session.

I have only just noticed this. Something has changed in the last few daily releases to trigger this behavior.

I'd also like to comment that clicking under "Help > Send feedback" sent me to a very unwelcoming webpage "Oh! So, you want to offer us feedback on the next version of Firefox. Thank you, but you'll need to be on our latest beta." It then tried to get me to install 4.0b7 (I'm running 4.0b8pre). Apart from the out of date issue, the language of this page is hostile and unwelcoming. "Oh. So you want to ..." - the sneer in those words is almost palpable. Not a good way to welcome someone to a community.
(Reporter)

Comment 1

8 years ago
After todays update to 4.0~b8~hg20101127r58302+nobinonly-0ubuntu1~umd1~lucid both issues still seem to be present. Indeed things seem worse as firefox no longer appears to warn that a previous instance exists that needs to be closed. Instead it apparently starts but fails to open any webpages. Running ps -A | grep firefox shows that unresponsive instances exist and only by killing these can one achieve a functional start.

Apologies if this is the wrong place to provide feedback on the beta, however 
attempting to provide feedback through the help menu still doesn't work apparently insisting on a downgrade to 4.0-b7 first. Perhaps that should be reported as another bug. 

In short updates over the last two days have caused some pretty serious regressions on my system to the point where minefield is now painful to use. I'm switching back to namoroka for my everyday browsing until these issues are sorted.
(Reporter)

Comment 2

8 years ago
Todays update to
4.0~b8~hg20101127r58305+nobinonly-0ubuntu1~umd1~lucid
seems to have fixed the problem.

So I guess I'll declare my own bug closed. Feel a bit like I'm talking to an empty room here. Oh well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.