Closed Bug 615039 Opened 12 years ago Closed 9 years ago

Add a preference to prevent dns lookup for a single word

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: tabutils+bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101126 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101126 Firefox/4.0b8pre

Currently, a single word in the location bar is treated as a host/url first, and a search will only be triggered after dns looking up fails. This usually feels slow. For most people, a single word is not necessary treated as a host/url. It would be better to have a hidden preference for this.

Reproducible: Always
And many ISPs/DNS providers hijack the failed dns looking up to their own search service. This is often quite annoying.
Severity: normal → major
Summary: Add a preference to prevent dns looking up for a single word in the location bar → Add a preference to prevent dns lookup for a single word
Version: unspecified → Trunk
Severity: major → normal
Yes, this is a major problem that I've been advocating for getting fixed for a while now. Since no one has picked it up, I'm going to fix it myself.
We are not planning to add a preference for this, but we are going to fix the underlying problem in bug 700474, so all users can benefit from it.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Still a valid concern.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Nobody said it wasn't a valid concern, but that adding a pref isn't the right way to deal with it.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago9 years ago
Resolution: --- → WONTFIX
I cant understand why FF does not care. So many people complaining. Many people switching to chrome....
You need to log in before you can comment on or make changes to this bug.