Closed Bug 615118 Opened 12 years ago Closed 12 years ago

StudiVZ, MeinVZ, SchülerVZ Chat Application broken in 4.0 Beta 7 and on Trunk

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: Tobbi, Unassigned)

References

()

Details

(Keywords: regression)

When logging in to StudiVZ, MeinVZ and SchülerVZ (which are German networks) and trying to use the chat function, it hangs on status 'Adding your friends and checking who’s online ...'.

Using the current final of the 3.6 branch, everything works as expected and you can use the Chat function normally.
Informed StudiVZ about this issue, waiting for reply.
Please try the Firefox safemode http://support.mozilla.com/en-US/kb/Safe+Mode.
Attach a stacktrace for the hang using the "add an attachment" link above if you still get the hang in the Firefox safemode.
- https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

I can't do that myself because I don't have an Account there. (too many friends, i have to use chatroulette)
(In reply to comment #2)
> Please try the Firefox safemode http://support.mozilla.com/en-US/kb/Safe+Mode.
> Attach a stacktrace for the hang using the "add an attachment" link above if
> you still get the hang in the Firefox safemode.
> - https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
> 
> I can't do that myself because I don't have an Account there. (too many
> friends, i have to use chatroulette)

Sorry, Matti. I didn't mean 'hang' as in AppHang, but rather that the "Loading friends" status stays forever. I guess it has nothing to do with Safe Mode in this case. IMO there's either a problem within Firefox or within StudiVZ, which is what I'm trying to find out.
Summary: StudiVZ, MeinVZ, SchülerVZ chat application hangs in 4.0 betas and on trunk → StudiVZ, MeinVZ, SchülerVZ chat application unusable in 4.0 betas and on trunk
The safemode part i still something to test because it disables addons, the hardware acceleration and more important the jit (Jägermonkey/tracemonkey).
It's also broken in safe mode (SeaMonkey trunk).
This Broke between Beta 6 <-> 7.

Error Console says:
Fehler: uncaught exception: [Exception... "Operation is not supported"  code: "9" nsresult: "0x80530009 (NS_ERROR_DOM_NOT_SUPPORTED_ERR)"  location: "http://static.pe.studivz.net/20101126-0/Js/build/phx-strophe.js Line: 583"]
Assignee: nobody → general
Component: General → JavaScript Engine
QA Contact: general → general
Summary: StudiVZ, MeinVZ, SchülerVZ chat application unusable in 4.0 betas and on trunk → StudiVZ, MeinVZ, SchülerVZ Chat Application broken in 4.0 Beta 7 and on Trunk
It's broken on a TM Build from http://hg.mozilla.org/tracemonkey/rev/2000c21b7910 too.
Let's find a Regression Range ...
Duplicate of this bug: 613233
This is WFM using today's Nightly.
Progression Range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=065c920fb372&tochange=a4813c8be814
=> fixed by Checkin of Bug 601803.
Status: NEW → RESOLVED
Closed: 12 years ago
Depends on: 601803
Resolution: --- → FIXED
Hmm.  Where are they doing a cross-compartment adopt?  Are they using document.domain?
blocking2.0: ? → betaN+
You need to log in before you can comment on or make changes to this bug.