Closed Bug 615131 Opened 9 years ago Closed 9 years ago

Installer crashes if 'Next' button is clicked while 'Looking for existing installation...' dialog is displayed

Categories

(Firefox :: Installer, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED FIXED
Firefox 4.0b9

People

(Reporter: majik, Assigned: rstrong)

References

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

During installation of Firefox 3.6.12, if you know you want to accept the default install options and you click "Next" quickly to get through the install, the installer crashes at the part where the "Looking for existing installation..." modal is displayed.

Reproducible: Always

Steps to Reproduce:
1. Start installer
2. Click Next 3 times
3. Sip your weak lemon drink
Attached patch patch rev1 (obsolete) — Splinter Review
Still need to test the patch... surprised no one has reported this before since this has been the case for several years.
Assignee: nobody → robert.bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Installer crashes if "Next" button is clicked while "Looking for existing installation..." dialog is mapped → Installer crashes if 'Next' button is clicked while 'Looking for existing installation...' dialog is displayed
Attached patch patch rev2Splinter Review
Attachment #493603 - Attachment is obsolete: true
Attachment #496473 - Flags: review?(jmathies)
Attachment #496473 - Flags: review?(jmathies) → review+
Attachment #496473 - Flags: approval2.0? → approval2.0+
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/ae9c1e421a16
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b9
You need to log in before you can comment on or make changes to this bug.