Last Comment Bug 615472 - Geolocation prompt should ask the user a question
: Geolocation prompt should ask the user a question
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: Firefox 11
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-29 22:22 PST by Alex Faaborg [:faaborg] (Firefox UX)
Modified: 2011-11-29 21:54 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (2.62 KB, patch)
2011-11-16 11:38 PST, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
gavin.sharp: review+
Details | Diff | Splinter Review

Description Alex Faaborg [:faaborg] (Firefox UX) 2010-11-29 22:22:40 PST
Currently the prompt contains the declarative statement:

site.domain.com wants to know your location.

As per the style guidelines for doorhangers, this needs to be a question, like:

Would you like to share your location with site.domain.com?
Comment 1 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2010-12-17 15:11:23 PST
Assuming we want this in Firefox 4, we'll want to block to make sure it gets [strings] attention.
Comment 2 Alex Faaborg [:faaborg] (Firefox UX) 2010-12-17 16:37:09 PST
Not a big enough issue to nominate, I was just getting it on file since I was reviewing all of the notifications for areweprettyyet
Comment 3 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-16 11:27:26 PST
I was going through old bugs of mine and found this...

There are actually 2 strings here, one for file and one for site. Since not both were specified in comment 0, I'm following up...

Site:
"%S wants to know your location." --> "Would you like to share your location with %S?"

File:
"The file %S wants to know your location." --> ?

I'm thinking we make it "Would you like to share your location with the file %S?" but wanted somebody from UX to give a yes/no.

Sooooo Limi, Boriss, Faaborg (if you're still following along with bugmail at all)?
Comment 4 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-16 11:38:50 PST
Created attachment 574950 [details] [diff] [review]
Patch v0.1

This is on the assumption that the file string I made is ok.
Comment 5 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-28 13:10:28 PST
https://hg.mozilla.org/integration/fx-team/rev/826bb288eb57
Comment 6 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-11-29 21:54:21 PST
https://hg.mozilla.org/mozilla-central/rev/826bb288eb57

Note You need to log in before you can comment on or make changes to this bug.