Last Comment Bug 615474 - Geolocation prompt alternate choices should be more descriptive
: Geolocation prompt alternate choices should be more descriptive
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: Firefox 11
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-29 22:27 PST by Alex Faaborg [:faaborg] (Firefox UX)
Modified: 2011-11-29 21:56 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (3.60 KB, patch)
2011-11-16 11:40 PST, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
gavin.sharp: review+
Details | Diff | Splinter Review

Description Alex Faaborg [:faaborg] (Firefox UX) 2010-11-29 22:27:38 PST
Currently the alternate choices for geolocation are "Always Share" and "Never Share" but the user has to read backwards in the notification to determine that their location is the implied thing being potentially shared.  Since users usually begin by reading the action button (and possibly alternate choices) before parsing the message itself, we should make sure that all information is contained in the choices:

Always Share Location
Never Share Location
Comment 1 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2010-12-17 15:20:29 PST
Assuming we want this in Firefox 4, we'll want to block to make sure it gets
[strings] attention.
Comment 2 Alex Faaborg [:faaborg] (Firefox UX) 2010-12-17 16:38:05 PST
we don't need this for 4
Comment 3 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-16 11:40:31 PST
Created attachment 574951 [details] [diff] [review]
Patch v0.1

Changed strings & got rid of geolocation.dontShareLocation (since it's not used anywhere)
Comment 4 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-28 13:10:59 PST
https://hg.mozilla.org/integration/fx-team/rev/1bfc734cbed3
Comment 5 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-11-29 21:56:01 PST
https://hg.mozilla.org/mozilla-central/rev/1bfc734cbed3

Note You need to log in before you can comment on or make changes to this bug.