All users were logged out of Bugzilla on October 13th, 2018

Crash pulling down Bookmark menu

VERIFIED DUPLICATE of bug 61519

Status

P3
critical
VERIFIED DUPLICATE of bug 61519
18 years ago
14 years ago

People

(Reporter: scalkins, Assigned: hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Saw this on Win32 2000-11-29-10, and Linux 2000-11-29-09
Note, I have a large bookmark menu 

Steps to repro:
1) Login to Webmail via the webmail icon on the Netscape Home page.
2) Click Exit Netscape Webmail in left pane.
3) Click button "Sign Out of Netscape Netcenter" in the next page.
4) When you are taken back to the home page, pull down the "Bookmarks" menu
5) Click and hold mouse while running down the bookmark menu list.

You will crash

If this doesn't crash for you, release the mouse, then follow steps 4 and 5 a 
second time


Talkback Trace Incident ID: 22032760 follows
 
Trigger Type:  Program Crash 

 Trigger Reason:  Access violation 

 Thread ID:   

 Call Stack:    (Signature = nsXBLPrototypeHandler::ExecuteHandler 1fc73499) 
     
   nsXBLPrototypeHandler::ExecuteHandler 
                                           
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLPrototypeHandler.cpp, line 297]
     
   nsXBLWindowHandler::WalkHandlersInternal
                                           
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowHandler.cpp, line 163]
     
   nsXBLWindowDragHandler::WalkHandlers 
                                           
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowDragHandler.cpp, line 
110]
     
   nsXBLWindowDragHandler::DragGesture 
                                           
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowDragHandler.cpp, line 
128]
     
   nsEventListenerManager::HandleEvent 
                                           
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
1530]
     
   nsWindowRoot::HandleChromeEvent 
                                           
[d:\builds\seamonkey\mozilla\dom\src\base\nsWindowRoot.cpp, line 187]
     
   GlobalWindowImpl::HandleDOMEvent 
                                           
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 582]
     
   nsXULDocument::HandleDOMEvent 
                                           
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 2011]
     
   nsXULElement::HandleDOMEvent 
                                           
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3477]
     
   nsXULElement::HandleDOMEvent 
                                           
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     
   nsXULElement::HandleDOMEvent 
                                           
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     
   nsXULElement::HandleDOMEvent 
                                           
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     
   nsEventStateManager::GenerateDragGesture
                                           
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
742]
     
   nsEventStateManager::PreHandleEvent 
                                           
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
300]
     
   PresShell::HandleEventInternal 
                                           
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4873]
     
   PresShell::HandleEvent 
                                           
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4813]
     
   nsView::HandleEvent 
                                           
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 379]
     
   nsView::HandleEvent 
                                           
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 352]
     
   nsViewManager2::DispatchEvent 
                                           
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1439]
     
   HandleEvent 
                                           
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 68]
     
   nsWindow::DispatchEvent 
                                           
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 690]
     
   nsWindow::DispatchWindowEvent 
                                           
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 707]
     
   nsWindow::DispatchMouseEvent 
                                           
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3940]
     
   ChildWindow::DispatchMouseEvent 
                                           
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4148]
     
   nsWindow::ProcessMessage 
                                           
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2999]
     
   nsWindow::WindowProc 
                                           
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 963]
     
   USER32.dll + 0x1820 (0x77e71820) 
                                            
     
   0x001b00de

Updated

18 years ago
Assignee: ben → hyatt

Comment 1

18 years ago
hyatt?

Comment 2

18 years ago
Betting on this being the same as bug 61519. But do please reopen if this 
isn't fixed by that patch.

*** This bug has been marked as a duplicate of 61519 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
verified [and doesn't crash anymore]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.