Last Comment Bug 615509 - Remove nsIDOMDOMConfiguration, Document.domConfig
: Remove nsIDOMDOMConfiguration, Document.domConfig
Status: RESOLVED FIXED
[wdc]
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla6
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 226193
  Show dependency treegraph
 
Reported: 2010-11-30 03:32 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-05-01 18:58 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (6.20 KB, patch)
2010-12-04 02:47 PST, :Ms2ger (⌚ UTC+1/+2)
jonas: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2010-11-30 03:32:32 PST
Those have never been implemented. Web DOM Core lays them to rest.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2010-12-04 02:47:55 PST
Created attachment 495228 [details] [diff] [review]
Patch v1

This is post-2.0.
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-03-11 18:00:34 PST
Comment on attachment 495228 [details] [diff] [review]
Patch v1

Could we also remove normalizeDocument() as it's just an alias for normalize()?
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-03-12 01:39:35 PST
Certainly. I filed bug 641190.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2011-03-30 10:19:03 PDT
This needs merging to tip (and probably IID changes to nsIDOM*Document, since it will now change nsIDOMDocument).
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2011-04-15 09:35:49 PDT
http://hg.mozilla.org/mozilla-central/rev/555c8cfbdb2d
Comment 6 Eric Shepherd [:sheppy] 2011-04-21 13:56:31 PDT
Updated documentation:

https://developer.mozilla.org/En/DOM/DOMConfiguration
https://developer.mozilla.org/en/DOM/document
https://developer.mozilla.org/En/DOM/Document.domConfig

And mentioned on Firefox 6 for developers.

Note You need to log in before you can comment on or make changes to this bug.