Closed Bug 615515 Opened 11 years ago Closed 11 years ago

Dragged out items from Download manager to a FF tab have a blurry thumbnail

Categories

(Toolkit :: Downloads API, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla2.0b8

People

(Reporter: vladmaniac, Assigned: dao)

References

Details

(Keywords: polish)

Attachments

(2 files, 1 obsolete file)

Attached image screenshot
Build ID:
Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101129 Firefox/4.0b8pre

Steps: 
1. Make sure you have some download history 
2. Bring up download manager 
3. Drag out an item onto a tab (this could be a doc file for e.g) 
4. Inspect UI of dragged item's thumbnail 

Behavior: 
Thumbnail appears blurry, the file name which is extracted from download manager looks abnormal (see screenshot). 

Note: 
This is reproducible also with the beta7 release candidate.
Keywords: polish, uiwanted
Is this a Regression against 3.6 or an earlier 4 Beta?
On WinXP this is not reproducible since i get no Image Preview at all...
I do not see the problem on 3.6
It regressed from 3.6 in the sense that now you are able to drag items out of the downloads window, and in Win 7 it looks ugly.

On XP using trunk you don't see the ugly text rendering as you drag the item over a tab. On Win 7 you can see the problem, at least all the way to Alpha 2, especially over a white background. It doesn't happen on 3.6.3 - 3.6.12 on XP because no thumbnail appears when you try to drag an item out of the downloads window.
Blocks: 462172
Component: Drag and Drop → Download Manager
Keywords: uiwanted
Product: Core → Toolkit
QA Contact: drag-drop → download.manager
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #494732 - Flags: review?(enndeakin)
Comment on attachment 494732 [details] [diff] [review]
set the whole item as the drag image

Using addElement instead of setDragImage would be more correct here.
Comment on attachment 494732 [details] [diff] [review]
set the whole item as the drag image

I'll try that.
Attachment #494732 - Flags: review?(enndeakin)
Attachment #494732 - Attachment is obsolete: true
Attachment #494741 - Flags: review?(enndeakin)
Attachment #494741 - Flags: review?(enndeakin) → review+
Attachment #494741 - Flags: approval2.0?
Attachment #494741 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/23aa5649204e
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
You need to log in before you can comment on or make changes to this bug.