Closed Bug 615829 Opened 9 years ago Closed 9 years ago

mCachedKeysCount/mExposeCacheUpdateStatus are initialized out of order in nsDOMOfflineResourceList::nsDOMOfflineResourceList

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla5

People

(Reporter: timeless, Assigned: timeless)

References

Details

Attachments

(1 file)

879 bytes, patch
mayhemer
: review+
Biesinger
: review+
Details | Diff | Splinter Review
dom/src/offline/nsDOMOfflineResourceList.h:
 In constructor ‘nsDOMOfflineResourceList::nsDOMOfflineResourceList(nsIURI*, nsIURI*, nsPIDOMWindow*, nsIScriptContext*)’:
120: warning: ‘nsDOMOfflineResourceList::mCachedKeysCount’ will be initialized after
115: warning:   ‘bool nsDOMOfflineResourceList::mExposeCacheUpdateStatus’
dom/src/offline/nsDOMOfflineResourceList.cpp:143: warning:   when initialized here
Blocks: 536295
Attached patch patchSplinter Review
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #494343 - Flags: review?(cbiesinger)
Attachment #494343 - Flags: approval2.0?
Attachment #494343 - Flags: review?(cbiesinger) → review+
Comment on attachment 494343 [details] [diff] [review]
patch

Mass minusing patch approval that don't have high return. Please renominate if this is more important for 2.0 than it appears.
Attachment #494343 - Flags: approval2.0? → approval2.0-
http://hg.mozilla.org/mozilla-central/rev/d0742b0dfa15
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: fixed-in-cedar
Target Milestone: --- → mozilla2.2
Duplicate of this bug: 608413
Component: DOM: Mozilla Extensions → DOM
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.