Closed Bug 615879 Opened 11 years ago Closed 6 months ago

IME composition doesn't start by typing a character for starting FAYT in auto-start mode

Categories

(Toolkit :: Find Toolbar, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 409754

People

(Reporter: masayuki, Unassigned)

References

Details

(Keywords: inputmethod)

Attachments

(1 file)

Attached patch Patch v1.0Splinter Review
1. Open IME on an editor (e.g., searchbar)
2. Enable auto-start of FAYT
3. type a character on web page

Actual result:

The input causes inputting a character without IME

Expected result:

IME starts composition in the editor of find toolbar

I worked for this bug on another bug (bug 483122). Following comments are posted to the bug.

> Masayuki Nakano (Mozilla Japan) 2010-11-30 07:48:52 PST
> 
> If bug 610821 is fixed by the posted patch's approach, the native keydown event
> will be sent to IME when our keydown event handler move focus to editor. So,
> the fix will make a possible way to fix this bug.
> 
> However, there is a serious problem about the FAYT spec. That is, even if
> auto-start is enabled, / or ' causes manual-start. Unfortunately, it cannot be
> checked in keydown event handler because we cannot know whether the pressed key
> has the characters in its shifted position. And also it means IME users cannot
> start by some characters which are assigned to same key as / or '.
> 
> So, to fix this bug, we need to find a new better behavior for i18n.
> 
> I think that we should kill the manual-start at auto-start mode for / and '. If
> so, we can provide same behavior to all keyboard layout users. However, it
> means that user cannot choose text-search-mode or link-only-mode if auto-start
> mode is enabled. This is bad.
> 
> Furthermore, there is another i18n problem, that is, some keyboard layout may
> need Shift key or Option key (on Mac) for inputting / or '. So, the shortcut
> key design is very bad for i18n.
> 
> Therefore, I think that we should define new shortcut keys for the
> manual-start. E.g., Function keys which don't depend on keyboard layout are
> better than / or '. But I'm not sure what keys are the best for them.
> 
> [reply] [-] Comment 11 Alex Faaborg [:faaborg] (Firefox UX) 2010-11-30 18:15:22 PST
> 
>>Therefore, I think that we should define new shortcut keys for the
>>manual-start. E.g., Function keys which don't depend on keyboard layout are
>>better than / or '. But I'm not sure what keys are the best for them.
> 
> Let's go with accel-/ and accel-' for now.
> 
> [reply] [-] Comment 12 Masayuki Nakano (Mozilla Japan) 2010-12-01 07:40:35 PST
> 
> Created attachment 494377 [details] [diff] [review]
> Patch v1.0
> 
> I'll request review after bug 610821 is finished.
Summary: Cannot start FAYT in auto-start mode by IME composition → Doesn't start IME composition when type a character for starting FAYT in auto-start mode
Summary: Doesn't start IME composition when type a character for starting FAYT in auto-start mode → IME composition doesn't start by typing a character for starting FAYT in auto-start mode
Priority: -- → P2

Resetting assignee which I don't work on in this several months.

Assignee: masayuki → nobody
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 409754
You need to log in before you can comment on or make changes to this bug.