Reduce Firefox button height in non-maximized windows on Windows XP

RESOLVED FIXED in Firefox 4.0b10

Status

()

defect
--
trivial
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: Mic, Assigned: dao)

Tracking

unspecified
Firefox 4.0b10
x86
Windows XP
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [hardblocker])

Attachments

(3 attachments, 6 obsolete attachments)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101130 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101130 Firefox/4.0b8pre

The app button too tall on Windows XP with "Embedded Standard" theme (this theme is one of the original themes from Microsoft that can be installed without any hacks).

See the attached screenshot for an example.

Reproducible: Always

Steps to Reproduce:
1. Hide menubar to show Firefox button.
Actual Results:  
Button is to tall.

Expected Results:  
Button should have normal height.

The button works fine (that is: ugly, but not too tall) with other themes (Luna, Windows Classic).

Bug 611732 is about a too tall button on Windows 2003 by the way.
Reporter

Comment 2

9 years ago
Set severity wrong. I guess it's more Minor (or even trivial, even though it is in a highly visible place I guess the number of affected users will be rather small).

Sorry for bugspam.
Severity: normal → minor
That's how it currently looks on all XP themes. If we want to morph this, I suppose we can. cc'ing Alex.
Summary: App button too tall on Windows XP with "Embedded Standard" theme → App button too tall on Windows XP
Assignee

Comment 4

9 years ago
Screenshot appears as intended.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Reporter

Comment 5

9 years ago
(In reply to comment #3)
> That's how it currently looks on all XP themes.

Somehow I made it look less tall on other themes. Maybe it was related to theme-switching while Minefield was running; If I can reproduce this I'll file another bug report.


(In reply to comment #4)
> Screenshot appears as intended.

Seems I missed the mockup then. It's still a pity: it looks cumbersome and in my view doesn't match the new and light look of Firefox.

The space between button and tab area is too narrow to allow the titlebar to 'effectively flow through it' in my opinion, giving the impression that the button is jamming or strangling the titlebar.
Yeah, I'm thinking that we might want to just go with the 7 height.  It won't be visually balanced with the native window controls, but they are pretty far away anyway.  There has also been some discussion of using 7 style window controls on XP just to look more modern (chrome did this as well), since the entire window frame is in XUL.  Having our own controls would also help us with personas.  Reopening for Stephen's opinion.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Summary: App button too tall on Windows XP → The Firefox button is too tall on Windows XP?
(In reply to comment #6)
> Yeah, I'm thinking that we might want to just go with the 7 height.  It won't
> be visually balanced with the native window controls, but they are pretty far
> away anyway.  There has also been some discussion of using 7 style window
> controls on XP just to look more modern (chrome did this as well), since the
> entire window frame is in XUL.  Having our own controls would also help us with
> personas.  Reopening for Stephen's opinion.

I think the default 7 size is 19px tall. Which might be a little too short because it leaves a pretty large gap between the button and the rest of the UI.

If the XP button were 22px tall instead of the 26/27px it is now the bottom should align with the bottom of the window control glyphs. That would look less chunky and more balanced.
Posted image titlebar pic
(In reply to comment #7)
> I think the default 7 size is 19px tall. Which might be a little too short
> because it leaves a pretty large gap between the button and the rest of the UI.
> 
> If the XP button were 22px tall instead of the 26/27px it is now the bottom
> should align with the bottom of the window control glyphs. That would look less
> chunky and more balanced.

The Fx button is currently alined with the bottom of the command buttons. I don't remember the bug # but when we made that change the XP button grew in heigh quite a bit.
I know the Firefox button isn't on by default for XP users, but we can count on the more savvy among them to turn it on and right now it looks pretty bad. Not only is it 5 pixels too tall compared to mocks but it sitting 2 pixels too far to the left causing it to spill outside of the window's corner radius. Also, the gradient doesn't match the mock-ups, which looks especially bad near the top of the button causing it to appear almost as if it's floating in front of the titlebar, not attached to it. 

With more than 50% of our users on XP, I think we should clean this up some before shipping.
Status: REOPENED → NEW
blocking2.0: --- → ?
Summary: The Firefox button is too tall on Windows XP? → The Firefox button is too tall on Windows XP
Reporter

Comment 11

9 years ago
This image shows the effects of my changes (I will attach the patch when the repository finished cloning): Luna-theme (bottom left) and Windows Embedded-theme (bottom right).

It's WIP and the normal state only so far (no changes made for :hover, :active, open and private mode).
If we can get this reviewed I definitely think we should take the fix.
I'd go a step further and say that if we can't generally clean up Firefox button size, position, and gradient, that we should disable the hide menubar option UI for XP users. 

It's really quite awful looking right now and I'd rather we make it clear that it's unfinished by disabling that option (letting an extension or hidden pref handle it) if we can't polish it up before release. 

(Benedikt, your screenshot looks great!)
Hard blocker - makes us look silly on a dominant platform.
blocking2.0: ? → final+
Whiteboard: [hardblocker]
Assignee

Comment 15

9 years ago
The button isn't enabled by default on XP.
blocking2.0: final+ → ?
Whiteboard: [hardblocker]
(In reply to comment #15)
> The button isn't enabled by default on XP.

Yeah, I know, that very thing came up in triage discussion with beltzner, but the quality of Firefox button is part of our release criteria, and we expect people to turn it on.
blocking2.0: ? → final+
Whiteboard: [hardblocker]
Assignee

Comment 17

9 years ago
I use XP on a daily basis with the button turned on.
Assignee

Comment 18

9 years ago
What the pictures also don't show is that the button is actually smaller in maximized windows, as it doesn't need to span the window border there. So we're talking about XP users surfing in non-maximized windows (minority) and opting in to the button (another minority).
Severity: minor → trivial
Assignee

Comment 19

9 years ago
Posted image screenshot (obsolete) —
Assignee

Updated

9 years ago
blocking2.0: final+ → ?
Whiteboard: [hardblocker]
Reporter

Comment 20

9 years ago
Posted image Mockup of button on maximized window (obsolete) —
The button on the screenshot from comment 19 looks good in my opinion. It takes the available space which would go unused otherwise. I edited a screenshot to suggest a few changes here, though.

The upper part is an actual screenshot, with the button sitting next to the screen border/corner.
In the mockup the button is extended to include the screenedge and corner to make it look more like 'one piece'. The blue space below the button is 3px now, like it is above the tab next to it. Even though 'looks better to me' might be a poor reason for this change;)

>---
Shall I spend further time to try to fix the look of the button as started in comment 11 or isn't it that urgent because the button will be disabled anyways? I'm not quite sure what the official opinion on this is at the moment?
Assignee

Comment 21

9 years ago
Can you please file separate bugs on suggestions like hiding the left border when maximized?
>Can you please file separate bugs on suggestions like hiding the left border
>when maximized?

I should note that we decided not to do this on Vista/7 so that we could match the design of the window controls.  We may later be using that general window control design for Firefox on XP as well.

>So we're
>talking about XP users surfing in non-maximized windows (minority) and opting
>in to the button (another minority).

yeah, but that subset is still probably an order of magnitude larger than the people using our OS X theme :)
Assignee

Comment 23

9 years ago
(In reply to comment #22)
> yeah, but that subset is still probably an order of magnitude larger than the
> people using our OS X theme :)

Let's say 50% of our users are on XP with a Luna-like theme (not classic), 20% of which don't surf maximized, 10% of which hide the menu bar. These rather high estimates would mean we're talking about 1% of our user. And then I doubt the tall button would offend these users as much as it offends Asa. While we could take a patch, a blocking issue looks very much different to me.
Assignee

Comment 24

9 years ago
Benedikt filed bug 625167 on button's left border in maximized windows.
>20% of which don't surf maximized

I would personally guess that part is higher, at least in terms of seeing a non-maximized window. But yeah, we are probably talking about <5-1%

We currently have a [hardblocker] on the star sometimes missing a tooltip, so in that context it seems strange that we are debating one of the most prominent aspects of our windows theme blocking (even if it is a <5% case).
Assignee

Comment 26

9 years ago
(In reply to comment #25)
> >20% of which don't surf maximized
> 
> I would personally guess that part is higher, at least in terms of seeing a
> non-maximized window. But yeah, we are probably talking about <5-1%

I don't know, but whenever I see a Windows notebook with a browser open in the wild, the window is maximized. Numbers for desktop with large screens might differ, but then XP probably doesn't correlate much with large screens...

> We currently have a [hardblocker] on the star sometimes missing a tooltip

Alright, can we drop that? :p
(In reply to comment #23)

> Let's say 50% of our users are on XP with a Luna-like theme (not classic)

Where does that 50% come from. I've never met an XP user who didn't work in software and changed their Windows theme. Not one.

If we can just lob guesses here, then let me give it a try. 

Let's say 90% of XP users are on the default Luna theme. Let's say 30% of them surf with restored rather than maximized windows. Let's say that 30% of Firefox users at least look the no menubar config, whether they stick with it or not. 

So now we're talking about an audience that dwarfs Linux and starts to rival Mac. 

But I just guessed at all those numbers so I'd like to put something else out there.  This isn't random "ok" or "cancel" button buried deep in options somewhere. This is the "Firefox" button -- this is our brand. This is the feature that will get more attention in the press and among users than any other new feature in Firefox. It's already going to be controversial.

No other browser vendor would ship this, not even Flock or Rockmelt or other kooky UI vendors. They'd clean it up or they'd turn it off.
Assignee

Comment 28

9 years ago
(In reply to comment #27)
> (In reply to comment #23)
> 
> > Let's say 50% of our users are on XP with a Luna-like theme (not classic)
> 
> Where does that 50% come from. I've never met an XP user who didn't work in
> software and changed their Windows theme. Not one.

Ok, and I didn't actually lower the estimate because of the theme... I said 50% of our users, not 50% of XP users.
Dao, you asked why this was a hardblocker and it was clearly answered in comment 16; please don't flip the flags again. This is and will continue to be a hard blocker, period. The Firefox Button is a major user-facing aspect of this release, and on any platform where we support it, we should support it right.
blocking2.0: ? → betaN+
Whiteboard: [hardblocker]
Assignee

Updated

9 years ago
Assignee: nobody → dao
Summary: The Firefox button is too tall on Windows XP → Reduce Firefox button height in non-maximized windows on Windows XP
Assignee

Comment 30

9 years ago
Posted patch patch (obsolete) — Splinter Review
No change to the texture or border, file new bugs for that.
Attachment #502644 - Attachment is obsolete: true
Attachment #502889 - Attachment is obsolete: true
Attachment #503253 - Attachment is obsolete: true
Attachment #503269 - Attachment is obsolete: true
Attachment #503791 - Flags: review?(gavin.sharp)
Assignee

Comment 31

9 years ago
Comment on attachment 503791 [details] [diff] [review]
patch

Oops, forgot to target non-maximized windows specifically.
Attachment #503791 - Flags: review?(gavin.sharp) → review-
Assignee

Comment 32

9 years ago
Posted patch patch (obsolete) — Splinter Review
Attachment #503791 - Attachment is obsolete: true
Attachment #503792 - Flags: review?(gavin.sharp)
Assignee

Comment 33

9 years ago
Comment on attachment 503792 [details] [diff] [review]
patch

Jim, please feel free to steal the review.
Attachment #503792 - Flags: review?(jmathies)
Assignee

Comment 34

9 years ago
Posted patch patchSplinter Review
ifndef WINSTRIPE_AERO added, we don't want this on Win7
Attachment #503792 - Attachment is obsolete: true
Attachment #503808 - Flags: review?(jmathies)
Attachment #503808 - Flags: review?(gavin.sharp)
Attachment #503792 - Flags: review?(jmathies)
Attachment #503792 - Flags: review?(gavin.sharp)
Attachment #503808 - Flags: review?(gavin.sharp) → review+
Assignee

Updated

9 years ago
Attachment #503808 - Flags: review?(jmathies)
Assignee

Comment 35

9 years ago
http://hg.mozilla.org/mozilla-central/rev/2e68d97b6932
Status: NEW → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
You need to log in before you can comment on or make changes to this bug.