Open Bug 616108 Opened 10 years ago Updated 3 months ago

Spell-checking in multiple languages

Categories

(Core :: Spelling checker, enhancement)

enhancement
Not set
normal

Tracking

()

UNCONFIRMED

People

(Reporter: henrique.rodrigues, Unassigned, NeedInfo)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.12) Gecko/20101027 Ubuntu/10.10 (maverick) Firefox/3.6.12
Build Identifier: 

Thunderbird's spell checker only allows a single language to be selected at a time. On the other hand, Evolution has an elegant way to allow the user to select multiple languages for spell-checking:

1. In Evolution's options, we have a list of all the installed dictionaries. We then select which dictionaries we want, using checkboxes;
2. When we are composing an e-mail using spell-check, Evolution uses all the selected dictionaries to find a match for words;
3. When we right-click on a marked word, we get a menu for each of the selected languages, each with their own suggestions. 

This would be a simple, yet great addition to Thunderbird, since many of us users are multilingual and use terms in another language (mostly English) in our normal writing.

Reproducible: Always

Steps to Reproduce:
1. Configure Thunderbird to use Portuguese spell-checking
2. Write an e-mail in Portuguese with some English words


Actual Results:  
See the English words marked by the spell-checker

Expected Results:  
1. Configure Thunderbird to use Portuguese and English spell-checking
2. Write an e-mail in Portuguese with some English words
3. See that all the words are recognized by the spell-checker
Component: General → Spelling checker
Product: Thunderbird → Core
QA Contact: general → spelling-checker
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 69687
I don't think this is a duplicate of bug 69687.
If to read 69687 the goal of that bug is to support multiple 
spell dictionaries but not at the same time.

Support of two or more spell dictionaries at the same time 
is addressed in this bug.
Please consider reopening of this bug.

Furthermore, this is a new feature proposal for all Mozilla applications
supporting spelling checks.
I think you're right, so I'll reopen it.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Do whatever you want, but so far all similar bugs were duped to that one.  De-duping will not help you get this fixed, if you're not able to support multiple dictionaries ta the same time. The exact mechanism how this would work (sequential dictionary testing, auto-detect, the lang-attribute or whatever method is used) is something else.
As a professional translator who works with many languages, I join this request. I do not want Thunderbird to claim that a text is incorrect when its own spell checkers should know that it s.
Check this for checking several languages simultaneously
https://bugzilla.mozilla.org/show_bug.cgi?id=660506
It looks like most problems that users report with repeatedly choosing ONE spell checking language would be satisfactorily solved if the user could once for all setup SEVERAL dictionaries to be used SIMULTANEOUSLY for the languages he can write, among those installed on his system.  That is especially needed for e-mail since many people write them in several languages (and that's the way Evolution does it).
It seems fairly simple to do, see  https://bugzilla.mozilla.org/show_bug.cgi?id=676500
(In reply to 2t2 from comment #2)
> I don't think this is a duplicate of bug 69687.
> If to read 69687 the goal of that bug is to support multiple 
> spell dictionaries but not at the same time.

I don't see how this is not a dupe of bug 69687.  

Bug 69687 IS most certainly all about "at the same time". 
For all mozilla apps, not just thunderbird or just firefox.
Are there other arguments to not dupe to 69687?

Furthermore, the key discussion is or probably will be occurring there (though there is relevant activity in bug 676500)
Dupe against 481884 that is more specific than bug 69687? See bug 481884 comment 10 for why not dupe against 69687.
This has been implemented in Google Chrome as described in https://plus.google.com/u/0/+FrancoisBeaufort/posts/5d56cbKjhLG. The code can be seen at https://codereview.chromium.org/1300213002.
(In reply to Alexander Popov from comment #11)
> Is it duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=69687?

This bug is not a duplicate of what's in the description of bug 69687, but the content of this bug has also been proposed in the comments of bug 69687, most recent in bug 69687 comment 162.

Is this supported in the latest version or not yet? I would also like to put in a request that this be added it might seem uncommon in the English speaking world, but in many many countries, writing emails in multiple languages happens regularly, and in those countries, the thunderbird single-language spellcheck simply isn't adequate.

Also, what's the point of labelling this as a duplicate and arguing about it if neither this nor the duplicate are getting addressed 9 years later? It sounds more like an attempt to brush it under the carpet than anything else.

I ended up making an extension that tries to detect the language used in each input field, then switches the spell checking to the correct language for that field: https://addons.mozilla.org/da/firefox/addon/automatic-spelling-language/

However, this isn't quite the same as spell checking in multiple languages at the same time, so I still hope this bug gets addressed.

(In reply to Jacob Bundgaard from comment #14)

I ended up making an extension that tries to detect the language used in each input field, then switches the spell checking to the correct language for that field: https://addons.mozilla.org/da/firefox/addon/automatic-spelling-language/

However, this isn't quite the same as spell checking in multiple languages at the same time, so I still hope this bug gets addressed.

This addon is only for Firefox, so not a solution for Thunderbird, right?

This 10 years old improvement proposal is still UNCONFIRMED, or the status field was not updated?
Is there a general consensus that it would make sense to implement this enhancement and is it clear how to do it?

I saw several tickets dealing with this same issue. This one here is the master ticket?

Flags: needinfo?(bugs)

(In reply to m from comment #15)

This addon is only for Firefox, so not a solution for Thunderbird, right?

I don't use Thunderbird, but it isn't a lot of code, so someone could probably port it: https://github.com/kimsey0/FirefoxAutoDict

You need to log in before you can comment on or make changes to this bug.