Closed Bug 61630 Opened 20 years ago Closed 19 years ago

Not able to render some web sites - causes problems in performance comparision test runs.

Categories

(SeaMonkey :: General, defect, P2, critical)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.8

People

(Reporter: chofmann, Assigned: harishd)

References

()

Details

(Keywords: embed)

Attachments

(6 files)

Version: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001031

This is a browser-general bug, Mozilla is not able to render the following 
sites, eventually timeout with missing images. This does not occur to Netscape 
4.7 or IE, so it could be problem with the Gecko rendering engine.

URLs:
http://www.target.com
http://www.hitbox.com
http://www.moviefone.com
http://www.lowestfare.com
http://www.biography.com



------- Additional Comments From lchiang@netscape.com 2000-11-27 23:33:34 ----

hmm, I just tried this on the Netscape 6 rtm release on WinNT and did not have 
any problems with rendering images on any of the above sites except for 
http://www.biography.com.

This bug should be moved to Bugzilla.



------- Additional Comments From sudheeragrawal@aol.com 2000-11-29 14:53:02 ----

Some images are not rendering.



------- Additional Comments From chofmann@netscape.com 2000-11-30 08:08:19 ----

I just tried this with netscape6 rtm on win98.
all the sites appeared to load ok except for
http://www.target.com

the exact error message I received was
"operation timed out when attempting to contact www.target.com"

I just tried 4.7x and also got the error response back that
"server could be down or not responding"

It sounds like we need to construct a good test case
where with pages where all or parts of the content
served is unavailable or simulate network flakeyness
to make good head way on understanding what might be happening
and protect against error conditions.   Its easy to think
about banner ads served from separated sites going down
and possible confusing page loading.

maybe tever has such a test????




------- Additional Comments From chofmann@netscape.com 2000-11-30 11:33:17 ----

and now latter in the day http://www.target.com

a few weeks back while on sabatical I was watching a cnbc
story about a entire reorg of the target web site.  I bet
this flakey behavior might be related to them trying
to keep the site running stable after a lot of hardware
and content reorg...

see folks, valuable thing come out of sabaticals... ;-)

we still need to design some good test case to simulate
flakey sites to make sure the browser behaves correctly,
and we need to make sure any performance
related tests accurately report "site unreachable"
and remove it from page loading time stats.
maybe this bug should be split into two for those
different areas but lets keep it together until
we know more.




------- Bug moved to this database by chofmann@netscape.com 2000-11-30 11:49 -------

This bug previously known as bug 3141 at http://bugscape.netscape.com/
http://bugscape.netscape.com/show_bug.cgi?id=3141
Originally filed under the Gecko Embedding product and Komodo component.

Unknown version unspecified in product Browser. Setting version to "other".
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here, chofmann@netscape.com.
   Previous reporter was xueddie@aol.com.

Sorry Chris, I don't have such a test at the moment.  I will look into setting 
up a page later today with missing content from various sources.  One question, 
have you tried this on winNT or only win98?  All the sites listed are working 
for me.
Several things jump out at me right away:
1) Several of the sites (like www.biography.com) use document.layers. Of course
we don't support this in NS6. That could be causing part of the problems.

2) In all the cases where we failed to fire an on end document load for these
urls, the only remaining channel in the load group was our dummy layout channel.
For some reason it isn't getting removed for these websites. Rick helped cook up
this channel so I'll cc him on this bug too. 
Status: NEW → ASSIGNED
Ever confirmed: true
I *think* this problem may have to do with the parser. The dummy layout channel
is never being removed from the load group. this is because the parser is never
call DidBuildModel on the html content sink. 
I've attached a band aid fix which at least allows the pages to properly load
and more importantly terminate. All I'm doing is allowing the dummy layout
channel to be removed when the # of outstanding remaining requests == 0.
Regardless of the state of the mIsLoading flag.

This flag is cleared only when the parser calls DidBuildModel. For these web
pages it isn't calling this method. The right fix is to keep digging and figure
out why this notification isn't going out.

I'll keep poking but I'm a little lost in the layout / parser code. 
I'm going to try to bring a big gun for this puppy. cc'ing rickg.

Hey Rick, so I'm having trouble loading some urls: www.target.com,
www.biography.com are a couple of examples.

Everything in the page lays out correctly. However, the html parser is never
firing a DidBuildModel notification on the content sink. I've stepped through
the debugger and the parser does receive an OnStopRequest notification for the
over-all document but that doesn't turn into a call to DidBuildModel for these
particular web pages.

I'm still debugging but if you have any insights on what kind of conditions
could prevent the htmlparser from firing a DidBuildModel it would be helpful.
Thanks!
Blocks: 64833
mscott wrote:

I'm still debugging but if you have any insights on what kind of conditions
could prevent the htmlparser from firing a DidBuildModel it would be helpful.

(A) DidBuildModel() may not get fired when the parser is blocked ( on loading 
JS,CSS, etc.. ).
When I was last looking at this, I tried loading each of the individual parts of
www.target by hand and didn't see anything we couldn't load or choked on
individually. I also looked at an http log and it appeared that we were getting
responses for each part when loading the overall document.

Not sure if that helps....
Summary: Not able to render some web sites → Not able to render some web sites - causes problems in performance comparision test runs.
Blocks: 64833
Add nsbeta1, embed keywords. This appears to be important for embedding.
Keywords: embed, nsbeta1
Attached file Testcase.
CC ing myself. 

Btw, I'm working on tracking down the problem.
mscott was right. I did not hit did build model at all!!!!!! 

Investigating.
Reassigning bug to myself. 
Target Milestone: --- → mozilla0.8
Moving to my plate for REAL!
Assignee: mscott → harishd
Status: ASSIGNED → NEW
Ok...the good news is that I'm very close to a fix. The bad news, however, is 
that I'm not 100% sure if it is the correct fix! Will update soon.

The bottom level is that we are ending up with a wrong parser context which 
messes up the timing.
Status: NEW → ASSIGNED
r=heikki for the patch harishd showed me. It is not the one in v1.1, right?
Please add the correct patch here as well.
Fix is in. Marking FIXED.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Ummm. ticketmaster.com & accuweather still seem to have the problem. Reopening
the bug until I fix all the sites.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ok, the problem with ticketmaster.com ( refer the reduced case id=24223 ) seems 
to be different. It's unable to load the image. However, if I replace the image 
src with an image in my local server 
( http://ortcloud.mcom.com/harishd/Bugs/Images/aim.gif) I don't see the problem.

Marking FIXED again.
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
verified fixed
Status: RESOLVED → VERIFIED
No longer blocks: 64833
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.