Closed Bug 616538 Opened 9 years ago Closed 9 years ago

Fennec on android crashes on startup when launched from sutagent on a tegra board with latest 2.2 OS

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jmaher, Assigned: blassey)

References

Details

(Whiteboard: [mobile_unittests] [mobile_dev_needed])

Attachments

(1 file)

from the sutagent, I run 'exec org.mozilla.fennec', and in adb shell: logcat, I see this:

D/dalvikvm( 1451): GC_EXPLICIT freed 2202 objects / 131968 bytes in 62ms
D/dalvikvm( 1451): GC_EXPLICIT freed 702 objects / 34664 bytes in 49ms
I/ActivityManager( 1022): Starting activity: Intent { dat=about:blank flg=0x10000000 pkg=org.mozilla.fennec cmp=org.mozilla.fennec/.App }
I/ActivityManager( 1022): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=1549 uid=10031 gids={3003, 1015, 3002, 3001}
D/dalvikvm( 1451): GC_EXPLICIT freed 319 objects / 15008 bytes in 46ms
D/dalvikvm( 1549): GC_FOR_MALLOC freed 2068 objects / 152216 bytes in 30ms
D/dalvikvm( 1549): GC_FOR_MALLOC freed 1854 objects / 136336 bytes in 25ms
I/GeckoApp( 1549): create
I/GeckoAppJava( 1549): Checking for an update
I/global  ( 1549): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
D/dalvikvm( 1549): Trying to load lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x4430a310
D/dalvikvm( 1549): Added shared lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x4430a310
D/dalvikvm( 1549): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozutils.so 0x4430a310, skipping init
I/GeckoApp( 1549): env0: null
I/GeckoApp( 1549): start
I/GeckoApp( 1549): resume
D/AndroidRuntime( 1549): Shutting down VM
W/dalvikvm( 1549): threadid=1: thread exiting with uncaught exception (group=0x4001d820)
E/AndroidRuntime( 1549): FATAL EXCEPTION: main
E/AndroidRuntime( 1549): java.lang.RuntimeException: Unable to resume activity {org.mozilla.fennec/org.mozilla.fennec.App}: java.lang.NullPointerException
E/AndroidRuntime( 1549): 	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:3128)
E/AndroidRuntime( 1549): 	at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:3143)
E/AndroidRuntime( 1549): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2684)
E/AndroidRuntime( 1549): 	at android.app.ActivityThread.access$2300(ActivityThread.java:125)
E/AndroidRuntime( 1549): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2033)
E/AndroidRuntime( 1549): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime( 1549): 	at android.os.Looper.loop(Looper.java:123)
E/AndroidRuntime( 1549): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
E/AndroidRuntime( 1549): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime( 1549): 	at java.lang.reflect.Method.invoke(Method.java:521)
E/AndroidRuntime( 1549): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
E/AndroidRuntime( 1549): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
E/AndroidRuntime( 1549): 	at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime( 1549): Caused by: java.lang.NullPointerException
E/AndroidRuntime( 1549): 	at org.mozilla.gecko.GeckoApp.onNewIntent(GeckoApp.java:236)
E/AndroidRuntime( 1549): 	at org.mozilla.gecko.GeckoApp.onResume(GeckoApp.java:299)
E/AndroidRuntime( 1549): 	at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1149)
E/AndroidRuntime( 1549): 	at android.app.Activity.performResume(Activity.java:3823)
E/AndroidRuntime( 1549): 	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:3118)
E/AndroidRuntime( 1549): 	... 12 more
W/ActivityManager( 1022):   Force finishing activity org.mozilla.fennec/.App
W/ActivityManager( 1022):   Force finishing activity com.mozilla.SUTAgentAndroid/.SUTAgentAndroid
W/ActivityManager( 1022): Activity pause timeout for HistoryRecord{4445a3d0 org.mozilla.fennec/.App}
I/AndroidRuntime( 1451): AndroidRuntime onExit calling exit(0)
I/ActivityManager( 1022): Process com.mozilla.SUTAgentAndroid (pid 1451) has died.
D/KeyguardViewMediator( 1022): pokeWakelock(5000)
D/StatusBar( 1022): DISABLE_EXPAND: yes
W/NotificationService( 1022): Object died trying to hide notification android.app.ITransientNotification$Stub$Proxy@444aba38 in package com.mozilla.SUTAgentAndroid
W/ActivityManager( 1022): setProcessForeground called on unknown pid: 1451
D/dalvikvm( 1270): GC_EXPLICIT freed 2531 objects / 176888 bytes in 62ms
I/power   ( 1022): *** set_screen_state 0
D/SurfaceFlinger( 1022): About to give-up screen, flinger = 0xa4da8
E/SurfaceFlinger( 1022): ioctl(30, VT_RELDISP, 1) failed 22 (Invalid argument)
W/SensorService( 1022): listener with binder android.hardware.SensorManager$ListenerDelegate@4443ab10, doesn't exist (sensor=tegra_accelerometer, id=1)
W/InputManagerService( 1022): Got RemoteException sending 'screen on/off' notification to pid 1451 uid 10031
D/        (  947): NVRM_DAEMON(977): pm_notifier_thread: calling power_displays(false)
D/        (  947): NVRM_DAEMON(980): pm_notifier_thread: returned from power_displays(false)
joel@joel-laptop:~/mozilla/android/android-sdk-linux_x86/tools$
Attached patch patchSplinter Review
Joel, can you confirm that this prevents you from crashing?
Assignee: nobody → blassey.bugs
Attachment #495134 - Flags: review?(mwu)
Attachment #495134 - Flags: feedback?(jmaher)
Attachment #495134 - Flags: review?(mwu)
Attachment #495134 - Flags: review+
Attachment #495134 - Flags: approval2.0?
Joel, ping?
I pushed this patch on a tryserver build and installed it locally with an older sutagent.  I was able to launch the process successfully and kill it as well.

I believe this solves the problem, thanks!
Attachment #495134 - Flags: approval2.0? → approval2.0+
I've also changed the agent to set an action upon launch, which will also keep this particular problem from happening.
Blocks: 561908
http://hg.mozilla.org/mozilla-central/rev/a199802e18b5
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Attachment #495134 - Flags: feedback?(jmaher)
Joel/Brad, can you verify this?
I don't have a tegra board, but Joel does.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.