Update Webtrends JS File

VERIFIED FIXED in 1.0

Status

www.mozilla.org
General
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: Laura Forrest, Assigned: jlongster)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

8 years ago
Please update the JS include file for the Mozilla.com site. File attached. 

Change log:

 
- Updated from TagBuilder version 3.0 to TagBuilder version 3.1.

- Updated customization to accept parameters via the constructor to add error checking.

- Updated sampling customization to apply to dcsMultiTrack calls, as well as automatic link tracking and download tracking.

- Added comments to all customizations so they can be identified quickly and easily.
(Reporter)

Comment 1

8 years ago
Created attachment 495078 [details]
Webtrends.js

Updated

8 years ago
Blocks: 619725
Assignee: abuchanan → jlong
Target Milestone: --- → 1.0
(Assignee)

Comment 2

8 years ago
I'll throw the file in.  Being new here, I need someone to help me figure out what I need to test to make sure it's working.
Status: NEW → ASSIGNED

Comment 3

8 years ago
You can use the httpFox plugin and search for http calls to the dcs.gif file going to the statse.webtrendslive.com domain. We want to see the query parameters passed on this call before and after replacing the JS include file to be identical. The updates are only to allow new functionality that we're not yet taking advantage of.

Keep in mind that due to sampling, each customer has only a 50/50 chance of passing anything at all to Webtrends. This is cookie-based, so if you're in the wrong 50%, clear cookies and try again.
(Assignee)

Comment 4

8 years ago
Created attachment 499130 [details]
test results

Thanks Wes.  Just performed that test.  There is one minor difference with the new JS file.  The new URL doesn't have the WT.z_bounce parameter.  See attachment for full URLs, here's a snipped version to show the difference:

The old URL:
...&WT.vt_f_a=2&WT.vt_f=2&WT.z_bounce=0

The new URL:
...&WT.vt_f_a=2&WT.vt_f=2

Is that a cause for concern?

Comment 5

8 years ago
Created attachment 499143 [details]
Updated 3.1 JS code with WT.z_bounce

Comment 6

8 years ago
Good catch - that was a piece of customization that was present in the old tag, but that we weren't aware of. I've implemented it in the new tag, tested for errors and functionality, and attached the updated JS include file to this bug.
(Assignee)

Comment 7

8 years ago
Created attachment 499174 [details] [diff] [review]
Final patch for webtrends.js

Here is the patch for integrating these changes.  I wasn't sure if I should paste just the patch or the whole file; I figure patches are better for being reviewed.
Attachment #495078 - Attachment is obsolete: true
Attachment #499130 - Attachment is obsolete: true
Attachment #499143 - Attachment is obsolete: true
Attachment #499174 - Flags: review?(abuchanan)
Attachment #499174 - Flags: review?(abuchanan) → review+
(Assignee)

Comment 8

8 years ago
r79831 | jlong@mozilla.com | 2010-12-22 16:32:26 -0500 (Wed, 22 Dec 2010) | 1 line

Bug 616567 - Update Webtrends JS File
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Keywords: push-needed
Duplicate of this bug: 608275
Duplicate of this bug: 619725
r79989 on production
Keywords: push-needed
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.