Ignoring alternate text of "" and using filename instead

VERIFIED DUPLICATE of bug 1994

Status

()

P3
normal
VERIFIED DUPLICATE of bug 1994
20 years ago
20 years ago

People

(Reporter: dbaron, Assigned: rickg)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

You're ignoring alternate text of "", i.e.,

<img alt="" src="some file...">

and using the filename of the image instead.  You should display no alternate
text if alt="", since in many cases alt="" should be used for images that are
merely decorative and would not be missed at all.

FYI, the HTML 4.0 spec has some very good suggestions for how to come up with
alternate text:

http://www.w3.org/TR/REC-html40/appendix/notes.html#altgen

Previous issues relating to alternate text were discussed in bug 1994.

This probably requires the equivalent of the DOM's Element::GetAttributeNode
rather than GetAttribute.  This may also be related to bug 6052.
This bug is one of many related to alternate text of images. All these bugs
have been marked. To find related bugs, search the description field for the
string "[ALT]".
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

20 years ago
*** This bug has been marked as a duplicate of 1994 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 3

20 years ago
Agreed. This is a duplicate of 1994.
You need to log in before you can comment on or make changes to this bug.