Closed Bug 616629 Opened 9 years ago Closed 2 years ago

"Remember Password?" dialog shows too early

Categories

(Toolkit :: Password Manager, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 558178

People

(Reporter: limi, Unassigned)

Details

(Keywords: ux-error-prevention)

With the notification bar, we asked whether to remember passwords when the page was actually loaded.

With the new doorhanger-style notifications, the question pops up immediately after you send the request to log in, and more importantly: before you know whether the login succeeded.

We should delay the remember password dialog until the page has actually rendered, so you know whether the password you entered was correct — so you don't store a bogus password just because the server was slow to respond.
Component: Account Manager → Password Manager
Product: Firefox → Toolkit
QA Contact: account.manager → password.manager
We didn't change when we show the notification (either bar or popup), so I don't think this is a regression.
Keywords: regression
(In reply to comment #1)
> We didn't change when we show the notification (either bar or popup), so I
> don't think this is a regression.

Are you sure? I don't think I've ever seen the notification bar without there being at least some part of a page rendered below it. (Not arguing about the inclusion of the keyword, just curious :)
I just tested this on 3.6, and Gavin is right.

I think waiting for the page to render would be a challenge, since there are often redirects when authenticating, so it would be tough to know which page we want to wait for. We could just introduce a time delay, but that seems like it could just make Firefox seem slower.
I think this is just a timer in 3.6, there is some slide-in effect.

Maybe the popup only shows after some page with content shows (eg not error or redirect, which is already another bug).
Er, um, has this bug been forgotten?

(I hope I'm not terribly annoying the 7 people on CC.)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558178
You need to log in before you can comment on or make changes to this bug.